Closed Bug 520089 Opened 10 years ago Closed 8 years ago

[10.6] Snow Leopard Firefox scrolling distorts page

Categories

(Firefox :: General, defect)

3.5 Branch
x86_64
macOS
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 555834

People

(Reporter: jonpa10den, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3

I have a MacBook Pro laptop and Firefox worked fine on Leopard.  After I upgraded to Snow Leopard I find each time I use Firefox to Browse I have a scrolling issue. As I scroll down the page I get a horizontal distortion level with where the mouse is.  The distortion is sufficiently bad that it makes it uncomfortable on the eyes.  This issue occurs when using the two finger touch pad scroll as well.

I have not detected this issue on any other application including the Safari browser.

Reproducible: Always

Steps to Reproduce:
1.None, it just plain happens every time I open the Firefox Browser
2.I tried shutting down completely and also tried closing out all tabs and not saving any
3.
Actual Results:  
Problem persisted


This problem occurs every time I use Firefox.  It really is tough on the eyes and I can't find any way to stop it.
Can you take a screenshot of the problem (if that even works)?
(In reply to comment #1)
> Can you take a screenshot of the problem (if that even works)?

No, that isn't possible.  I tried but this condition only works when using the vertical scroll and a screen shot can't be done while the image is on the move.  
I tried making a video of the issue but the "capture rate" of the video smooths out the problem pretty much.  I did try uploading a Flash swf file of it but the file was too big.  However, it as I say, it doesn't capture too well the issue.
(In reply to comment #2)
> Possibly related: on Windows I see a similar problem here:
> http://clang.llvm.org/features.html#enduser
> https://bugzilla.mozilla.org/show_bug.cgi?id=517820#c3

This does look like a related issue albeit Windows
Summary: Snow Leopard Firefox scrolling distorts page → [10.6] Snow Leopard Firefox scrolling distorts page
Just as an experiment, try this:
 1. Quit Firefox.
 2. Open the file Info.plist with Property List Editor.
    This file is in the "Contents" folder that you see when you right-click on
    Firefox.app and choose "Show Package Contents".
 3. Delete the row that says "CGDisableCoalescedUpdates", save the file and
    launch Firefox.

Does this fix it?
Hello, I have also had this problem and following Markus' instructions fixed it.  Tearing issues in various forms of video (Flash, QuickTime, etc) were also eliminated.  Thank you.
Version: unspecified → 3.5 Branch
Reporter, Firefox 4.0.1 has been released, and it features significant improvements over previous releases. Can you please update to Firefox 4.0.1 or later, and retest your bug? Please also create a fresh profile (
http://support.mozilla.com/kb/Managing+profiles), update your plugins (Flash, Java, Quicktime, Reader, etc) and update your graphics driver and Operating system to the latest versions available. 

If you still continue to see this issue, please comment. If you do not, please close this bug as RESOLVED > WORKSFORME

filter: prefirefox4uncobugs
No reply, INCOMPLETE. Please retest with Firefox 5 or later and a new profile (http://support.mozilla.com/kb/Managing+profiles). If you continue to see this issue with the newest firefox and a new profile, then please comment on this bug.
Status: UNCONFIRMED → RESOLVED
Closed: 8 years ago
Resolution: --- → INCOMPLETE
Resolution: INCOMPLETE → DUPLICATE
Duplicate of bug: 555834
You need to log in before you can comment on or make changes to this bug.