Closed Bug 520106 Opened 12 years ago Closed 12 years ago

When restoring previous tabs, it shows multiple master password requests

Categories

(Firefox :: General, defect)

x86_64
Windows XP
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 348997

People

(Reporter: alejandrofm, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3 (.NET CLR 3.5.30729)

I have 2 sites that have a popup that ask for a password and some other sites with simple password fields.
I close Firefox, save tabs, restart firefox and it opens almost one master password request per tab (requesting login), It should ask only once for master password.
When entering all the passwords would be hard to identify a foreign window that ask for master password.

Reproducible: Always

Steps to Reproduce:
1.Open tabs with pop-up logins and sites with regular login (no pop up).
2.close firefox, save tabs
3.open firefox
Actual Results:  
it shows more than 1 Master password request

Expected Results:  
it should show only one master password request
Status: UNCONFIRMED → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 348997
You need to log in before you can comment on or make changes to this bug.