No context menu when watching a video in full screen mode

RESOLVED FIXED in mozilla13

Status

()

defect
RESOLVED FIXED
10 years ago
7 years ago

People

(Reporter: u88484, Unassigned)

Tracking

unspecified
mozilla13
Points:
---
Dependency tree / graph
Bug Flags:
wanted1.9.2 +

Firefox Tracking Flags

(Not tracked)

Details

()

Reporter

Description

10 years ago
There is no content menu when watching a video in fullscreen mode.

STR:
1) Go to http://commons.wikimedia.org/wiki/File:Bird_flock_at_Westerland,_Sylt.ogg
2) Push play button
3) Right-click on the video and select 'Full Screen'
4) After video resumes playing now in full screen, right-click again and no context menu appears
Flags: wanted1.9.2?
Reporter

Updated

10 years ago
Summary: No context menu when watching a video in fullscreen mode → No context menu when watching a video in full screen mode
As per Dão's recent blog posting it appears that this is simply not implemented yet http://design-noir.de/log/2009/10/firefox-3-6-plays-html5-videos-full-screen/
Flags: wanted1.9.2? → wanted1.9.2+
Not really a core bug...
Blocks: 453063
Reporter

Comment 3

10 years ago
I wasn't sure where to file it and since it deals with video, I figured this would be the best place until someone decides elsewhere.

BTW, having a context menu in fullscreen would be a parity of at least flash.  The current video options presented while in non-fullscreen mode are very useful and would also be useful inside fullscreen mode.
Component: Video/Audio → Video/Audio Controls
Product: Core → Toolkit
QA Contact: video.audio → video.audio
Version: 1.9.2 Branch → unspecified
This bug has been fixed for quite some time and so should probably be marked as such by someone with the permission to do so.

Comment 5

7 years ago
Mozilla/5.0 (X11; Linux i686; rv:10.0.5) Gecko/20100101 Firefox/10.0.5

This issue still reproduces on Firefox 10.0.5 ESR for ogg videos (e.g.http://videos.mozilla.org/firefox4beta/Firefox_4_beta.theora.ogv).
(In reply to Christopher Robert Jaquez from comment #4)
> This bug has been fixed for quite some time and so should probably be marked
> as such by someone with the permission to do so.

Can you please point out where and when this was fixed?
Reproducible also on Firefox 10.0.6 ESR:

Mozilla/5.0 (Windows NT 5.1; rv:10.0.6) Gecko/20100101 Firefox/10.0.6
Does this bug exist in the latest Firefox 20.0a1 Nightly builds as well (ie. not just esr10)?
This was fixed by switching to DOM Fullscreen. Thanks for bringing attention to this Anthony.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Depends on: 702894
Target Milestone: --- → mozilla13
You need to log in before you can comment on or make changes to this bug.