Closed Bug 520384 Opened 10 years ago Closed 9 years ago

TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/places/tests/browser/browser_library_infoBox.js | Selected element in detailsDeck is infoBox. - Got 0, expected 1

Categories

(Firefox :: Bookmarks & History, defect)

x86
Linux
defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 3.7a5

People

(Reporter: jrmuizel, Assigned: mak)

References

Details

(Keywords: intermittent-failure)

Attachments

(1 file)

An intermittent failure on linux:

TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/places/tests/browser/browser_library_infoBox.js | Selected element in detailsDeck is infoBox. - Got 0, expected 1
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/places/tests/browser/browser_library_infoBox.js | Expander button is hidden for all bookmarks node.
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/places/tests/browser/browser_library_infoBox.js | Additional info field correctly collapsed: #editBMPanel_descriptionRow
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/places/tests/browser/browser_library_infoBox.js | Additional info field correctly collapsed: #editBMPanel_loadInSidebarCheckbox
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/places/tests/browser/browser_library_infoBox.js | Additional info field correctly collapsed: #editBMPanel_keywordRow
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/places/tests/browser/browser_library_infoBox.js | Selected element in detailsDeck is infoBox. - Got 0, expected 1
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/places/tests/browser/browser_library_infoBox.js | Expander button is hidden for history node.
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/places/tests/browser/browser_library_infoBox.js | Additional info field correctly collapsed: #editBMPanel_descriptionRow
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/places/tests/browser/browser_library_infoBox.js | Additional info field correctly collapsed: #editBMPanel_loadInSidebarCheckbox
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/places/tests/browser/browser_library_infoBox.js | Additional info field correctly collapsed: #editBMPanel_keywordRow
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/places/tests/browser/browser_library_infoBox.js | Selected element in detailsDeck is infoBox. - Got 0, expected 1
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/places/tests/browser/browser_library_infoBox.js | Expander button is hidden for history child node.
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/places/tests/browser/browser_library_infoBox.js | Additional info field correctly collapsed: #editBMPanel_descriptionRow
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/places/tests/browser/browser_library_infoBox.js | Additional info field correctly collapsed: #editBMPanel_loadInSidebarCheckbox
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/places/tests/browser/browser_library_infoBox.js | Additional info field correctly collapsed: #editBMPanel_keywordRow
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/places/tests/browser/browser_library_infoBox.js | Expander button is hidden for history item.
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/places/tests/browser/browser_library_infoBox.js | Additional info field correctly collapsed: #editBMPanel_descriptionRow
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/places/tests/browser/browser_library_infoBox.js | Additional info field correctly collapsed: #editBMPanel_loadInSidebarCheckbox
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/places/tests/browser/browser_library_infoBox.js | Additional info field correctly collapsed: #editBMPanel_keywordRow
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/places/tests/browser/browser_library_infoBox.js | Selected element in detailsDeck is infoBox. - Got 0, expected 1
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/places/tests/browser/browser_library_infoBox.js | Expander button is hidden for bookmarks menu node.
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/places/tests/browser/browser_library_infoBox.js | Additional info field correctly collapsed: #editBMPanel_descriptionRow
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/places/tests/browser/browser_library_infoBox.js | Additional info field correctly collapsed: #editBMPanel_loadInSidebarCheckbox
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/places/tests/browser/browser_library_infoBox.js | Additional info field correctly collapsed: #editBMPanel_keywordRow
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/places/tests/browser/browser_library_infoBox.js | Selected element in detailsDeck is infoBox. - Got 0, expected 1
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/places/tests/browser/browser_library_infoBox.js | Selected element in detailsDeck is infoBox. - Got 0, expected 1
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/places/tests/browser/browser_library_infoBox.js | Additional info field correctly hidden by default: #editBMPanel_descriptionRow
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/places/tests/browser/browser_library_infoBox.js | Additional info field correctly hidden by default: #editBMPanel_loadInSidebarCheckbox
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/places/tests/browser/browser_library_infoBox.js | Additional info field correctly hidden by default: #editBMPanel_keywordRow
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/places/tests/browser/browser_library_infoBox.js | Selected element in detailsDeck is infoBox. - Got 0, expected 1
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/places/tests/browser/browser_library_middleclick.js | window made active - Got [object ChromeWindow], expected [object ChromeWindow]
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/places/tests/browser/browser_library_middleclick.js | window made active - Got [object ChromeWindow], expected [object ChromeWindow]
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/places/tests/browser/browser_library_middleclick.js | window made active - Got [object ChromeWindow], expected [object ChromeWindow]
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/places/tests/browser/browser_library_middleclick.js | window made active - Got [object ChromeWindow], expected [object ChromeWindow]
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/places/tests/browser/browser_library_middleclick.js | window made active - Got [object ChromeWindow], expected [object ChromeWindow]
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/places/tests/browser/browser_library_panel_leak.js | Editing a bookmark - Didn't expect -1, but got it

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1254590153.1254591875.21570.gz
Blocks: 438871
Whiteboard: [orange]
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1256746267.1256748874.22556.gz
Linux mozilla-central test everythingelse on 2009/10/28 09:11:07  

TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/places/tests/browser/browser_library_infoBox.js | Selected element in detailsDeck is infoBox. - Got 0, expected 1
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/places/tests/browser/browser_library_infoBox.js | Expander button is hidden for all bookmarks node.
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/places/tests/browser/browser_library_infoBox.js | Additional info field correctly collapsed: #editBMPanel_descriptionRow
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/places/tests/browser/browser_library_infoBox.js | Additional info field correctly collapsed: #editBMPanel_loadInSidebarCheckbox
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/places/tests/browser/browser_library_infoBox.js | Additional info field correctly collapsed: #editBMPanel_keywordRow
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/places/tests/browser/browser_library_infoBox.js | Selected element in detailsDeck is infoBox. - Got 0, expected 1
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/places/tests/browser/browser_library_infoBox.js | Expander button is hidden for history node.
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/places/tests/browser/browser_library_infoBox.js | Additional info field correctly collapsed: #editBMPanel_descriptionRow
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/places/tests/browser/browser_library_infoBox.js | Additional info field correctly collapsed: #editBMPanel_loadInSidebarCheckbox
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/places/tests/browser/browser_library_infoBox.js | Additional info field correctly collapsed: #editBMPanel_keywordRow
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/places/tests/browser/browser_library_infoBox.js | Selected element in detailsDeck is infoBox. - Got 0, expected 1
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/places/tests/browser/browser_library_infoBox.js | Expander button is hidden for history child node.
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/places/tests/browser/browser_library_infoBox.js | Additional info field correctly collapsed: #editBMPanel_descriptionRow
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/places/tests/browser/browser_library_infoBox.js | Additional info field correctly collapsed: #editBMPanel_loadInSidebarCheckbox
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/places/tests/browser/browser_library_infoBox.js | Additional info field correctly collapsed: #editBMPanel_keywordRow
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/places/tests/browser/browser_library_infoBox.js | Expander button is hidden for history item.
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/places/tests/browser/browser_library_infoBox.js | Additional info field correctly collapsed: #editBMPanel_descriptionRow
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/places/tests/browser/browser_library_infoBox.js | Additional info field correctly collapsed: #editBMPanel_loadInSidebarCheckbox
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/places/tests/browser/browser_library_infoBox.js | Additional info field correctly collapsed: #editBMPanel_keywordRow
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/places/tests/browser/browser_library_infoBox.js | Selected element in detailsDeck is infoBox. - Got 0, expected 1
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/places/tests/browser/browser_library_infoBox.js | Expander button is hidden for bookmarks menu node.
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/places/tests/browser/browser_library_infoBox.js | Additional info field correctly collapsed: #editBMPanel_descriptionRow
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/places/tests/browser/browser_library_infoBox.js | Additional info field correctly collapsed: #editBMPanel_loadInSidebarCheckbox
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/places/tests/browser/browser_library_infoBox.js | Additional info field correctly collapsed: #editBMPanel_keywordRow
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/places/tests/browser/browser_library_infoBox.js | Selected element in detailsDeck is infoBox. - Got 0, expected 1
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/places/tests/browser/browser_library_infoBox.js | Selected element in detailsDeck is infoBox. - Got 0, expected 1
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/places/tests/browser/browser_library_infoBox.js | Additional info field correctly hidden by default: #editBMPanel_descriptionRow
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/places/tests/browser/browser_library_infoBox.js | Additional info field correctly hidden by default: #editBMPanel_loadInSidebarCheckbox
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/places/tests/browser/browser_library_infoBox.js | Additional info field correctly hidden by default: #editBMPanel_keywordRow
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/places/tests/browser/browser_library_infoBox.js | Selected element in detailsDeck is infoBox. - Got 0, expected 1
OS: Mac OS X → Linux
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1260469778.1260473123.14470.gz
Linux mozilla-central opt test everythingelse on 2009/12/10 10:29:38
s: moz2-linux-slave24
Blocks: 559354
Whiteboard: [orange] → [orange][needs investigation]
I have also seen this happen on the Fedora unit tests (mochitest-other is currently hidden).
yeah, this is still one of the topfails, I hope to find time to fix it, for sure needs action.
Assignee: nobody → mak77
hm, this thing should wait for focus in the left pane before going on, Linux is lazier regarding focus calls.
I can reproduce in Ubuntu 64
Attached patch patch v1.0Splinter Review
While i was absolutely able to reproduce the failure, with this patch I've never been able, thus it should be fine for current Fedora almost permaorange.
Attachment #444682 - Flags: review?(dietrich)
Attachment #444682 - Flags: review?(dietrich) → review+
I'm resolving, since I think this could do that, we can reopen if I'm wrong.

http://hg.mozilla.org/mozilla-central/rev/3ca7a0a4de55
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Whiteboard: [orange][needs investigation] → [orange]
Target Milestone: --- → Firefox 3.7a5
comment 13 is prior to the fix.
Flags: in-testsuite+
Whiteboard: [orange]
You need to log in before you can comment on or make changes to this bug.