Personal vcard editing shouldn't have a "photo" tab.

RESOLVED FIXED in Thunderbird 3.0rc1

Status

RESOLVED FIXED
9 years ago
5 years ago

People

(Reporter: el.cameleon.1, Assigned: philor)

Tracking

({fixed-seamonkey2.0})

1.9.1 Branch
Thunderbird 3.0rc1
fixed-seamonkey2.0

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; fr; rv:1.9.0.14) Gecko/2009090216 Ubuntu/9.04 (jaunty) Firefox/3.0.14
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; fr; rv:1.9.1.4pre) Gecko/20090915 Thunderbird/3.0b4

When you edit your personal vcard, there is a new tab called "photo", but this tab has no content.

Reproducible: Always

Steps to Reproduce:
1. Open your account settings
2. Edit your personal vcard
3. Go to the "photo" tab
Actual Results:  
no content into this tab

Expected Results:  
2 possibility:
- "photo" tab could be deleted has it has no content
OR
- The UI allowing to choose a photo should be displayed in this tab (has for a normal contact editing)
(Assignee)

Updated

9 years ago
Status: UNCONFIRMED → NEW
Component: Account Manager → Address Book
Ever confirmed: true
OS: Linux → All
Product: Thunderbird → MailNews Core
QA Contact: account-manager → address-book
Hardware: x86 → All
Summary: Personal vcard editing got an empty "photo" tab. → Personal vcard editing shouldn't have a "photo" tab.
Version: unspecified → 1.9.1 Branch
(Assignee)

Comment 1

9 years ago
Created attachment 404556 [details] [diff] [review]
Fix v.1

It's empty in Thunderbird because the patch in bug 119459 intended to punt on photos for vcards for now, but it did it by adding the tab content box to the list of things that are collapsed for vcards in Thunderbird, and not doing anything for SeaMonkey, where you get a perfectly usable (and ultimately useless since it doesn't go anywhere) photo tab. Instead, it should have meant to hide the whole tab, the same rather twisted way we only let you have the statutory one address by hiding the "Home" tab.
Assignee: nobody → philringnalda
Status: NEW → ASSIGNED
Attachment #404556 - Flags: superreview?(neil)
Attachment #404556 - Flags: review?(bugzilla)
(Assignee)

Updated

9 years ago
Target Milestone: --- → Thunderbird 3.0rc1
(Reporter)

Comment 2

9 years ago
Thanks for the feedback. 
From your comment, I understand that " Bug 247154 -  Inline vCard Editing UI Lacks Home Address Editing " will never be fixed. Is it right? Because some people (and me) still hope a fix (as the bug is mark "NEW"), so maybe an explanation is needed.
(In reply to comment #2)
> Thanks for the feedback. 
> From your comment, I understand that " Bug 247154 -  Inline vCard Editing UI
> Lacks Home Address Editing " will never be fixed. Is it right? Because some
> people (and me) still hope a fix (as the bug is mark "NEW"), so maybe an
> explanation is needed.

Your assumptions are incorrect. The only time a bug will *never* be fixed is if it gets marked as WONTFIX.
Attachment #404556 - Flags: superreview?(neil) → superreview+
Attachment #404556 - Flags: review?(bugzilla)
Attachment #404556 - Flags: review+
Attachment #404556 - Flags: approval-thunderbird3+
Comment on attachment 404556 [details] [diff] [review]
Fix v.1

/me sighs. We always forget the vcard dialog :-(
(Assignee)

Comment 5

9 years ago
http://hg.mozilla.org/comm-central/rev/11eb8c57e700
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Keywords: fixed-seamonkey2.0

Comment 6

5 years ago
There is no tab called "Photo" on Thunderbird 24.6.0

Only "General", "Work" and "Other".

How is possible add a photo on vcard?
You need to log in before you can comment on or make changes to this bug.