Closed Bug 520480 Opened 13 years ago Closed 11 years ago

Sidebar is empty and tab options unresponsive

Categories

(SeaMonkey :: Sidebar, defect)

PowerPC
macOS
defect
Not set
major

Tracking

(Not tracked)

RESOLVED INCOMPLETE

People

(Reporter: lloyd1981, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.4; en-US; rv:1.9.1.4pre) Gecko/20091003 SeaMonkey/2.0pre
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.4; en-US; rv:1.9.1.4pre) Gecko/20091003 SeaMonkey/2.0pre

Unable to load bookmarks or any other option to sidebar. "Add tabs" does nothing. Can open review window, but "OK" unresponsive. Must "Cancel" to close window. Considering extensive use, extremely inconvenient.

Reproducible: Always

Steps to Reproduce:
1.Start Seamonkey.
2.
3.
Actual Results:  
Sidebar is empty.

Expected Results:  
Filled tabs should appear.

I consider this a major bug. Function should follow form. What is expected should be there.
Please try in Safe mode ( http://kb.mozillazine.org/Talk:Safe_Mode#Safe_Mode_in_SeaMonkey_2 ), or with a new profile ( http://kb.mozillazine.org/Profile_Manager#Creating_a_new_profile ).

Do you get any error/warning/message in the Error Console ?
Component: General → Sidebar
QA Contact: general → sidebar
Version: unspecified → Trunk
I see this with SM trunk on Mac, but not on Linux.
If sidebar is configured to be open and I open a new browser window, I get:

Error: uncaught exception: [Exception... "Component returned failure code: 0x80004003 (NS_ERROR_INVALID_POINTER) [nsIRDFService.GetDataSource]"  nsresult: "0x80004003 (NS_ERROR_INVALID_POINTER)"  location: "JS frame :: chrome://communicator/content/sidebar/sidebarOverlay.js :: sidebar_open_default_panel :: line 819"  data: no]

I, too, am on Tiger, though - Stefan, do you see this on Leopard?
(Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.4; en-US; rv:1.9.1.4pre) Gecko/20091005 SeaMonkey/2.0pre here.)
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: blocking-seamonkey2.0+
Assignee: nobody → mnyromyr
I can't reproduce this on 10.5 with todays nightly. In one of my profiles I have 2 menuitems for each search provider in the drop-down, though.
Drilling down with Venkman, I found that my profile's panels.rdf is gone?!
Looking into the profile, I found that panels.rdf was symlinked(!) to non-existing file in my source tree (I build SeaMonkey myself)!
(panels.rdf got moved in bug 475113.)

So, this seems like build error in certain old profiles for self-made builds (the file should never have been symlinked).

Lloyd, can you confirm this?
works on 10.5 (Intel) without any problem on todays Polish nightly
Profile panels.rfd in place. ~/Library/Application Support/SeaMonkey/Profiles/z5hypved.default/panels.rdf  Have not personally "made" builds.

Been in and out of town. Just installed 20091008015039 and for first time in more than a week, restart opened tabs - but Bookmarks reads "This tab not available right now." If I open History, let it load, then click on Bookmarks, that tab will fill up. (This has been an ongoing issue for quite some time, but held off because easily corrected on temporary basis.)

Built from http://hg.mozilla.org/releases/mozilla-1.9.1/rev/bcfccb9bfd02

Will continue to monitor.
Does it fully work with a new profile, then?
Have not tried new profile yet. Will do so. But since my post, I have quit and started three times and tabs load (this session, bookmarks load) each time. Will try some housecleaning as well... want to install fresh directory and check for fragged files.
This is marked blocking 2.0 but we should be cutting the final RC any day now
(actually, any day after today makes us probably slip the ideal release date) -
so any ETA to get this resolved? Or is it not blocking after all?
My confirmation doesn't match the case, according to comment #6, thus UNCO again.
Noone else sees this, thus non-blocking.
Status: NEW → UNCONFIRMED
Ever confirmed: false
Flags: blocking-seamonkey2.0+
Works fine with new profile. Loads much quicker than default profile. One item to consider: quantity of bookmarks (?). There are over 500, with a number of nested folders. I can pare down, export, create another profile, import and go from there.
Imported the bookmarks into new profile and all loaded quickly - no problem with sidebar. Unfortunately, a lot of work has to be done to reposition bookmarks in main toolbar and there seems to be no way to import dataform fill into. Passwords, etc. all have to be re-entered (and the opsys really does not have a "fill form" factor anyway, which seems to me to be a waste since there are so many other options available). One of the best tricks of the old IE was to auto-fill order forms and other table data.

The capability to retain tab settings from load to load frequently requires a reset of the prefs file, depending on how prefs are treated with nightly builds, when there should be a one-time selection like in Firefox and Camino (and I am also working with Namaroka and Shiira 2.2). But, of course, that it for another entry.
I have never believed that the best way to solve a problem is to create a new user, particular when components such as cookies and passwords are integral parts of the program.

I have discovered that by turning off the URL avatars, closing the tabs view, quitting SeaMonkey, starting SeaMonkey then opening "View... Sidebar" the sidebar appears with the 4 tab headings.

Unfortunately, SeaMonkey has never really worked properly with the tabs since more often than not, bookarks won't appear. By clicking on, say, History, letting the tab column fill, then going back to bookmarks, bookmarks appear without hesitation.

End of this road for me. Running beta on a new accounting program.

Regards to all, Lloyd
Assignee: mnyromyr → nobody
Status: UNCONFIRMED → RESOLVED
Closed: 11 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.