Crash at [@ nsMediaCache::FindReusableBlock] during mochitests

RESOLVED WORKSFORME

Status

()

Core
Audio/Video
--
critical
RESOLVED WORKSFORME
9 years ago
6 years ago

People

(Reporter: nthomas, Unassigned)

Tracking

({crash, intermittent-failure})

1.9.2 Branch
x86
Linux
crash, intermittent-failure
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

9 years ago
http://tinderbox.mozilla.org/showlog.cgi?tree=Firefox-Unittest&errorparser=unittest&logfile=1254728410.1254728913.5673.gz&buildtime=1254728410&buildname=Linux%20mozilla-central%20test%20mochitests&fulltext=1#err1

41444 INFO Running /tests/content/media/test/test_source_write.html...
[snip 'Leaked URLs' list]
NEXT ERROR TEST-UNEXPECTED-FAIL | automation.py | Exited with code 1 during test run
INFO | automation.py | Application ran for: 0:07:26.149178
TEST-UNEXPECTED-FAIL | automation.py | application crashed (minidump found)
Operating system: Linux
                  0.0.0 Linux 2.6.18-53.1.19.el5 #1 SMP Wed May 7 08:20:19 EDT 2008 i686 GNU/Linux
CPU: x86
     GenuineIntel family 13 model 23 stepping 8
     1 CPU

Crash reason:  SIGSEGV
Crash address: 0x12f02fd

Thread 0 (crashed)
 0  libxul.so!nsMediaCache::FindReusableBlock(mozilla::TimeStamp, nsMediaCacheStream*, int, int) [nsMediaCache.cpp:c75a0852ea72 : 719 + 0x0]
    eip = 0x012f02fd   esp = 0xbfb8a6e0   ebp = 0xbfb8a748   ebx = 0x01a3277c
    esi = 0x00000019   edi = 0x9fcb3000   eax = 0xab7f502c   ecx = 0x00000007
    edx = 0x0000007c   efl = 0x00010202
 1  libxul.so!nsMediaCache::Update() [nsMediaCache.cpp:c75a0852ea72 : 1029 + 0x1f]
    eip = 0x012f210a   esp = 0xbfb8a750   ebp = 0xbfb8b828
 2  libxul.so!UpdateEvent::Run() [nsMediaCache.cpp:c75a0852ea72 : 1241 + 0x8]
    eip = 0x012f2ec7   esp = 0xbfb8b830   ebp = 0xbfb8b848

This build was rev c75a0852ea72, which seems unrelated. Maybe an occasionaly crasher introduced by
 http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=2ceeabcf3a12&tochange=f39c6fb004c9
Hard to imagine it was any of those changes, but I don't know.  There have been some major changes to the media cache recently (e.g. bug 513144), but they've been on trunk since 2009-09-20, which would mean this was a pretty rare crash if introduced then.
There's a good chance this is caused by bug 523814.

Updated

9 years ago
Severity: normal → critical
Keywords: crash
Summary: Crash at nsMediaCache::FindReusableBlock during mochitests → Crash at [@ nsMediaCache::FindReusableBlock] during mochitests

Updated

8 years ago
Whiteboard: [orange]
No recent occurrences.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
(Assignee)

Updated

7 years ago
Crash Signature: [@ nsMediaCache::FindReusableBlock]
(Assignee)

Updated

6 years ago
Keywords: intermittent-failure
(Assignee)

Updated

6 years ago
Whiteboard: [orange]
You need to log in before you can comment on or make changes to this bug.