copying from search results list does not work

RESOLVED DUPLICATE of bug 177740

Status

--
enhancement
RESOLVED DUPLICATE of bug 177740
9 years ago
9 years ago

People

(Reporter: jan-mozilla, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.22) Gecko/20090605 SeaMonkey/1.1.17 (Ubuntu-1.1.17+nobinonly-0ubuntu0.9.04.1)
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.22) Gecko/20090605 SeaMonkey/1.1.17 (Ubuntu-1.1.17+nobinonly-0ubuntu0.9.04.1)

After doing a search on E-mail folders, a list is returned.
I can select messages from that list.
However, hitting control-C does not copy the list to the clipboard, and thus I cannot use this list in other applications.
Right-clicking on the list does not yield a panel either.
I use this feature in Microsoft Outlook regularly.

Note that copying from a folder to a text application does not paste the list of names either, as it does in Outlook.

This report might also apply to thunderbird (which I don't have installed)

Reproducible: Always

Steps to Reproduce:
1. search
2. select messages
3. try to copy
Actual Results:  
Nothing (copy disabled in both search results and folder listing)

Expected Results:  
Copy the list of messages to the clipboard, with columns as shown in the window.
I use this feature in Microsoft Outlook regularly.


Filed for Ubuntu as
https://bugs.launchpad.net/ubuntu/+source/seamonkey/+bug/429854

Comment 1

9 years ago
Please try how it works in SeaMonkey 2.0
Component: General → MailNews: Message Display
QA Contact: general → message-display
(Reporter)

Comment 2

9 years ago
A quick check in SeaMonkey 2.0 beta 2 shows it does NOT work there either.
I agree that fixing this in the 2.0 version rather than 1.x is more appropriate.
Note that in the version list of this mozilla page, I cannot select a 2.0 branch.

Updated

9 years ago
Version: unspecified → Trunk

Comment 3

9 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.4pre) Gecko/20091004 Lightning/1.0pre SeaMonkey/2.0pre

1) Search any messages

2) Select messages

3) Ctrl-C

4) Open any .txt file and hitting Ctrl-V  - doesn't copy list messages

This procedure is correct for the reconstruction of the problem?
OS: Linux → All
Hardware: x86 → All
(Reporter)

Comment 4

9 years ago
Indeed.

Comment 5

9 years ago
Duplicate on Bug 177740 ?
(Reporter)

Comment 6

9 years ago
Indeed, and of 
https://bugzilla.mozilla.org/show_bug.cgi?id=352776
excuse me for not finding them.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 177740
You need to log in before you can comment on or make changes to this bug.