If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Weave 0.7 does not sync even after a "start over"

RESOLVED DUPLICATE of bug 443386

Status

Cloud Services
General
--
major
RESOLVED DUPLICATE of bug 443386
8 years ago
8 years ago

People

(Reporter: Harald.Kurz, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3 (.NET CLR 3.5.30729)
Build Identifier: weave 0.7 in Firefox 3.5.3

Weave continuously fails to sync bookmarks with server. Attached log for error description in actual results section.

Reproducible: Always

Actual Results:  
Contents of logfile:
2009-10-06 16:05:48	Service.Main         INFO	Logs reinitialized for service reset
2009-10-06 16:05:48	Service.Main         DEBUG	Event: weave:service:reset-service:finish
2009-10-06 16:05:48	Engine.Clients       DEBUG	Event: weave:engine:reset-client:start
2009-10-06 16:05:48	Engine.Clients       DEBUG	Resetting clients last sync time
2009-10-06 16:05:48	Store.Clients.Store  DEBUG	Wiping local clients store
2009-10-06 16:05:48	Engine.Clients       DEBUG	Event: weave:engine:reset-client:finish
2009-10-06 16:05:48	Engine.Bookmarks     DEBUG	Event: weave:engine:reset-client:start
2009-10-06 16:05:48	Engine.Bookmarks     DEBUG	Resetting bookmarks last sync time
2009-10-06 16:05:48	Engine.Bookmarks     DEBUG	Event: weave:engine:reset-client:finish
2009-10-06 16:05:48	Engine.Forms         DEBUG	Event: weave:engine:reset-client:start
2009-10-06 16:05:48	Engine.Forms         DEBUG	Resetting forms last sync time
2009-10-06 16:05:48	Engine.Forms         DEBUG	Event: weave:engine:reset-client:finish
2009-10-06 16:05:48	Engine.History       DEBUG	Event: weave:engine:reset-client:start
2009-10-06 16:05:48	Engine.History       DEBUG	Resetting history last sync time
2009-10-06 16:05:48	Engine.History       DEBUG	Event: weave:engine:reset-client:finish
2009-10-06 16:05:48	Engine.Passwords     DEBUG	Event: weave:engine:reset-client:start
2009-10-06 16:05:48	Engine.Passwords     DEBUG	Resetting passwords last sync time
2009-10-06 16:05:48	Engine.Passwords     DEBUG	Event: weave:engine:reset-client:finish
2009-10-06 16:05:48	Engine.Prefs         DEBUG	Event: weave:engine:reset-client:start
2009-10-06 16:05:48	Engine.Prefs         DEBUG	Resetting prefs last sync time
2009-10-06 16:05:48	Engine.Prefs         DEBUG	Event: weave:engine:reset-client:finish
2009-10-06 16:05:48	Engine.Tabs          DEBUG	Event: weave:engine:reset-client:start
2009-10-06 16:05:48	Engine.Tabs          DEBUG	Resetting tabs last sync time
2009-10-06 16:05:48	Engine.Tabs          DEBUG	Event: weave:engine:reset-client:finish
2009-10-06 16:05:48	Service.Main         DEBUG	Event: weave:service:reset-client:finish
2009-10-06 16:05:48	Service.Main         INFO	Reset client data from freshStart.
2009-10-06 16:05:48	Service.Main         INFO	Client metadata wiped, deleting server data
2009-10-06 16:05:48	Service.Main         DEBUG	Event: weave:service:wipe-server:start
2009-10-06 16:05:49	Net.Resource         DEBUG	GET request for https://sj-weave08.services.mozilla.com/0.5/franlor/info/collections
2009-10-06 16:05:49	Net.Resource         DEBUG	GET success: 200
2009-10-06 16:05:49	Service.Main         DEBUG	Event: weave:service:wipe-server:finish
2009-10-06 16:05:51	Service.Main         DEBUG	Uploading new metadata record
2009-10-06 16:05:51	Service.Main         DEBUG	Setting meta payload storage version to 0.7
2009-10-06 16:05:51	Net.Resource         DEBUG	PUT Length: 82
2009-10-06 16:05:52	Net.Resource         DEBUG	PUT request for https://sj-weave08.services.mozilla.com/0.5/franlor/storage/meta/global
2009-10-06 16:05:52	Net.Resource         DEBUG	PUT success: 200
2009-10-06 16:05:52	Service.Main         INFO	Metadata record not found, server wiped to ensure consistency.
2009-10-06 16:05:52	PubKeyManager        TRACE	Importing record: https://sj-weave08.services.mozilla.com/0.5/franlor/storage/keys/pubkey
2009-10-06 16:05:53	Net.Resource         DEBUG	GET request for https://sj-weave08.services.mozilla.com/0.5/franlor/storage/keys/pubkey
2009-10-06 16:05:53	Net.Resource         DEBUG	GET fail: 404
2009-10-06 16:05:53	Service.Main         DEBUG	Could not get public key
2009-10-06 16:05:53	PubKeyManager        DEBUG	Generating RSA keypair
2009-10-06 16:05:57	PubKeyManager        DEBUG	Generating RSA keypair... done
2009-10-06 16:05:57	Net.Resource         DEBUG	PUT Length: 553
2009-10-06 16:05:58	Net.Resource         DEBUG	PUT request for https://sj-weave08.services.mozilla.com/0.5/franlor/storage/keys/pubkey
2009-10-06 16:05:58	Net.Resource         DEBUG	PUT success: 200
2009-10-06 16:05:58	Net.Resource         DEBUG	PUT Length: 1879
2009-10-06 16:05:59	Net.Resource         DEBUG	PUT request for https://sj-weave08.services.mozilla.com/0.5/franlor/storage/keys/privkey
2009-10-06 16:05:59	Net.Resource         DEBUG	PUT success: 200
2009-10-06 16:06:00	Net.Resource         DEBUG	GET request for https://sj-weave08.services.mozilla.com/0.5/franlor/info/collections
2009-10-06 16:06:00	Net.Resource         DEBUG	GET success: 200
2009-10-06 16:06:00	Service.Main         TRACE	Refreshing client list
2009-10-06 16:06:00	Engine.Clients       DEBUG	Event: weave:engine:sync:start
2009-10-06 16:06:00	Engine.Clients       DEBUG	Ensuring server crypto records are there
2009-10-06 16:06:00	RecordMgr            TRACE	Importing record: https://sj-weave08.services.mozilla.com/0.5/franlor/storage/crypto/clients
2009-10-06 16:06:01	Net.Resource         DEBUG	GET request for https://sj-weave08.services.mozilla.com/0.5/franlor/storage/crypto/clients
2009-10-06 16:06:01	Net.Resource         DEBUG	GET fail: 404
2009-10-06 16:06:01	Engine.Clients       WARN	Sync failed
2009-10-06 16:06:01	Engine.Clients       DEBUG	Event: weave:engine:sync:error
2009-10-06 16:06:01	Engine.Clients       INFO	Total (ms): sync 699, syncStartup 699
2009-10-06 16:06:01	Service.Main         DEBUG	Event: weave:service:sync:error
2009-10-06 16:06:01	Service.Main         DEBUG	Next sync in 5687 sec.
2009-10-06 16:06:01	Service.Main         CONFIG	Starting backoff, next sync at:Tue Oct 06 2009 17:40:48 GMT+0200
2009-10-06 16:06:01	Service.Main         DEBUG	Exception: Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [IWeaveCrypto.generateRandomKey] Stack trace: SyncEngine__syncStartup()@engines.js:359 < anonymous()@engines.js:207 < SyncEngine__sync()@engines.js:662 < anonymous()@engines.js:207 < WrappedNotify()@util.js:115 < Engine_sync()@engines.js:217 < anonymous()@service.js:1123 < WrappedNotify()@util.js:115 < WrappedLock()@util.js:87 < WrappedCatch()@util.js:66 < sync()@service.js:1088 < anonymous()@service.js:470 < notify()@util.js:624
2009-10-06 16:12:33	Service.Main         DEBUG	Event: weave:service:sync:start
2009-10-06 16:12:33	Service.Main         DEBUG	Fetching global metadata record
2009-10-06 16:12:33	RecordMgr            TRACE	Importing record: https://sj-weave08.services.mozilla.com/0.5/franlor/storage/meta/global
2009-10-06 16:12:34	Net.Resource         DEBUG	GET request for https://sj-weave08.services.mozilla.com/0.5/franlor/storage/meta/global
2009-10-06 16:12:34	Net.Resource         DEBUG	GET success: 200
2009-10-06 16:12:34	Service.Main         DEBUG	Weave Version: 0.7 Compatible: 0.6pre3 Remote: 0.7
2009-10-06 16:12:35	Net.Resource         DEBUG	GET request for https://sj-weave08.services.mozilla.com/0.5/franlor/info/collections
2009-10-06 16:12:35	Net.Resource         DEBUG	GET success: 200
2009-10-06 16:12:35	Service.Main         TRACE	Refreshing client list
2009-10-06 16:12:35	Engine.Clients       DEBUG	Event: weave:engine:sync:start
2009-10-06 16:12:35	Engine.Clients       DEBUG	Ensuring server crypto records are there
2009-10-06 16:12:35	RecordMgr            TRACE	Importing record: https://sj-weave08.services.mozilla.com/0.5/franlor/storage/crypto/clients
2009-10-06 16:12:36	Net.Resource         DEBUG	GET request for https://sj-weave08.services.mozilla.com/0.5/franlor/storage/crypto/clients
2009-10-06 16:12:36	Net.Resource         DEBUG	GET fail: 404
2009-10-06 16:12:36	Engine.Clients       WARN	Sync failed
2009-10-06 16:12:36	Engine.Clients       DEBUG	Event: weave:engine:sync:error
2009-10-06 16:12:36	Engine.Clients       INFO	Total (ms): sync 733, syncStartup 733
2009-10-06 16:12:36	Service.Main         DEBUG	Event: weave:service:sync:error
2009-10-06 16:12:36	Service.Main         DEBUG	Next sync in 7582 sec.
2009-10-06 16:12:36	Service.Main         CONFIG	Starting backoff, next sync at:Tue Oct 06 2009 18:18:58 GMT+0200
2009-10-06 16:12:36	Service.Main         DEBUG	Exception: Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [IWeaveCrypto.generateRandomKey] Stack trace: SyncEngine__syncStartup()@engines.js:359 < anonymous()@engines.js:207 < SyncEngine__sync()@engines.js:662 < anonymous()@engines.js:207 < WrappedNotify()@util.js:115 < Engine_sync()@engines.js:217 < anonymous()@service.js:1123 < WrappedNotify()@util.js:115 < WrappedLock()@util.js:87 < WrappedCatch()@util.js:66 < sync()@service.js:1088 < onclick()@about:weave:1
2009-10-06 16:13:05	Service.Main         DEBUG	Event: weave:service:sync:start
2009-10-06 16:13:05	Service.Main         DEBUG	Fetching global metadata record
2009-10-06 16:13:05	RecordMgr            TRACE	Importing record: https://sj-weave08.services.mozilla.com/0.5/franlor/storage/meta/global
2009-10-06 16:13:06	Net.Resource         DEBUG	GET request for https://sj-weave08.services.mozilla.com/0.5/franlor/storage/meta/global
2009-10-06 16:13:06	Net.Resource         DEBUG	GET success: 200
2009-10-06 16:13:06	Service.Main         DEBUG	Weave Version: 0.7 Compatible: 0.6pre3 Remote: 0.7
2009-10-06 16:13:07	Net.Resource         DEBUG	GET request for https://sj-weave08.services.mozilla.com/0.5/franlor/info/collections
2009-10-06 16:13:07	Net.Resource         DEBUG	GET success: 200
2009-10-06 16:13:07	Service.Main         TRACE	Refreshing client list
2009-10-06 16:13:07	Engine.Clients       DEBUG	Event: weave:engine:sync:start
2009-10-06 16:13:07	Engine.Clients       DEBUG	Ensuring server crypto records are there
2009-10-06 16:13:07	RecordMgr            TRACE	Importing record: https://sj-weave08.services.mozilla.com/0.5/franlor/storage/crypto/clients
2009-10-06 16:13:08	Net.Resource         DEBUG	GET request for https://sj-weave08.services.mozilla.com/0.5/franlor/storage/crypto/clients
2009-10-06 16:13:08	Net.Resource         DEBUG	GET fail: 404
2009-10-06 16:13:08	Engine.Clients       WARN	Sync failed
2009-10-06 16:13:08	Engine.Clients       DEBUG	Event: weave:engine:sync:error
2009-10-06 16:13:08	Engine.Clients       INFO	Total (ms): sync 997, syncStartup 997
2009-10-06 16:13:08	Service.Main         DEBUG	Event: weave:service:sync:error
2009-10-06 16:13:08	Service.Main         DEBUG	Next sync in 8457 sec.
2009-10-06 16:13:08	Service.Main         CONFIG	Starting backoff, next sync at:Tue Oct 06 2009 18:34:04 GMT+0200
2009-10-06 16:13:08	Service.Main         DEBUG	Exception: Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [IWeaveCrypto.generateRandomKey] Stack trace: SyncEngine__syncStartup()@engines.js:359 < anonymous()@engines.js:207 < SyncEngine__sync()@engines.js:662 < anonymous()@engines.js:207 < WrappedNotify()@util.js:115 < Engine_sync()@engines.js:217 < anonymous()@service.js:1123 < WrappedNotify()@util.js:115 < WrappedLock()@util.js:87 < WrappedCatch()@util.js:66 < sync()@service.js:1088 < onclick()@about:weave:1

Updated

8 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 443386
You need to log in before you can comment on or make changes to this bug.