[HTML5] Blogspot aka Blogger toolbar auto crashes Minefield 3.7a1pre [@nsHtml5TreeOpExecutor::ExecuteScript() ]

VERIFIED DUPLICATE of bug 520929

Status

()

Core
HTML: Parser
--
critical
VERIFIED DUPLICATE of bug 520929
9 years ago
9 years ago

People

(Reporter: Priit Uring, Unassigned)

Tracking

Trunk
x86
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a1pre) Gecko/20091006 Minefield/3.7a1pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a1pre) Gecko/20091006 Minefield/3.7a1pre

Blogpsot is famous blog site and should work with future Firefox !

Reproducible: Always

Steps to Reproduce:
1.go to any blog on blogspot
2.click blog link and wait 0 sec for crash
3.or try safe mode, cached web page on Google search
Actual Results:  
All steps made Minefield crash. Even using safe mode and Googles cached web page content rendering.

Expected Results:  
Web page should  have been shown and loaded.

Comment 1

9 years ago
(In reply to comment #0)
> 2.click blog link and wait 0 sec for crash

What link? Please be more specific. I clicked various links and got no crash.

Please also post a crash ID:
https://developer.mozilla.org/en/How_to_get_a_stacktrace_for_a_bug_report
Severity: normal → critical
Version: unspecified → Trunk
(Reporter)

Comment 2

9 years ago
Crash stat that has finished processing, can't be 100% it's blgospot crash stat because I have got some other sites crashing my browser >
http://crash-stats.mozilla.com/report/index/4f929c4d-74d1-44b6-bdfd-ab9a22091006?p=1

I had already posted link of Google's blog on blogspot on the bug form box url details and will re-post it as a Comment the> http://www.googleblog.blogspot.com
(Reporter)

Comment 3

9 years ago
Peter(6) had confirmed crash on XP, should ask his crash stat(ID)?
(Reporter)

Comment 4

9 years ago
Seems for some no reason Html5 was set enabled , setting it false doesn't crash.. , why safe mode didn't disable html5 :( I don't know..

Comment 5

9 years ago
dup of bug 520929?
Whiteboard: DUPME

Comment 6

9 years ago
(In reply to comment #5)
> dup of bug 520929?

Yeah, I think so. All looks like the same HTML5 engine crash.

0  	xul.dll  	nsHtml5TreeOpExecutor::ExecuteScript  	 parser/html/nsHtml5TreeOpExecutor.cpp:438
1 	xul.dll 	nsHtml5TreeOpExecutor::MaybeExecuteScript 	parser/html/nsHtml5TreeOpExecutor.cpp:509
2 	xul.dll 	nsHtml5StreamParser::ParseUntilSuspend 	parser/html/nsHtml5StreamParser.cpp:610
...
...

Looks like the same crash is hitting on various different pages.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Component: General → HTML: Parser
Product: Firefox → Core
QA Contact: general → parser
Resolution: --- → DUPLICATE
Summary: Blogspot aka Blogger toolbar auto crashes Minefield 3.7a1pre → [HTML5] Blogspot aka Blogger toolbar auto crashes Minefield 3.7a1pre [@nsHtml5TreeOpExecutor::ExecuteScript() ]
Whiteboard: DUPME
Duplicate of bug: 520929

Updated

9 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.