Closed Bug 520843 Opened 12 years ago Closed 12 years ago

Repeating events stored in Horde Kronolith are displayed one hour off in lightning when daylight savings changes

Categories

(Calendar :: Provider: ICS/WebDAV, defect)

x86
Windows XP
defect
Not set
major

Tracking

(Not tracked)

RESOLVED INVALID

People

(Reporter: dewi, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3 (.NET CLR 2.0.50727; .NET CLR 3.0.4506.2152; .NET CLR 3.5.30729)
Build Identifier: Thunderbird version 2.0.0.23 (20090812) with Lightning 0.9 build 2008091719

We're using lightning to provide access to our horde calendars in kronolith via ICS feeds. Everything is quite good except that repeating events which cross daylight savings boundaries do NOT display the correct time in lighting.

I have created events in kronolith and viewed them in lighting and also created the events from withing lightning. repeating event running from 9th october 2009 to 12 june 2010 every friday 12:00pm to 1:00pm. events display correctly until October 30th, then they display starting at 11:00am to 12:00pm this continues until March 12 2010, then on March 19th displays correctly again as 12:00pm to 1:00pm. In Horde Kronolith, the events display the correct time throughout the year.

The ICS entry that is downloaded for this event set is :-

BEGIN:VEVENT
DTSTART:20091009T190000Z
DTEND:20091009T200000Z
DTSTAMP:20091006T191617Z
UID:20091005162537.101736mvrmvmfj3l@www.brentwood.bc.ca
CREATED:20091005T232537Z
LAST-MODIFIED:20091005T232537Z
SUMMARY:recuring brentwood event
ORGANIZER;CN=Dewi Griffiths:mailto:dewi@brentwood.bc.ca
CATEGORIES:staff meetings
LOCATION:offices
CLASS:PUBLIC
STATUS:CONFIRMED
TRANSP:OPAQUE
RRULE:FREQ=WEEKLY;INTERVAL=1;BYDAY=FR;UNTIL=20100613T065959Z
END:VEVENT

If we create the event in thunderbird in the ics subscribed calendar, we see similar results:
the events are created in lightning, they span the time period and are displayed with the correct time throughout. the event spec is sent up to the web based horde calendar and we see every event correctly in horde, but when we reload the remote feed, the events that fall between the daylight savings time cutoffs are displayed 1 hour off.


Reproducible: Always

Steps to Reproduce:
1.create repeating event that spans daylight saving/standard time cutover (we use america/vancouver timezone) in web based calendar program.
2.View resulting events in lightning via am ics web feed.
3.
Actual Results:  
repeating events created starting in daylight saving time, and passing in to standard time display stored on a webdav ics based calendar feed, display one hour earlier when in standard time (winter)
> DTSTART:20091009T190000Z
> DTEND:20091009T200000Z

The event sent by your server is specified in fixed Coordinated Universal Time (UTC) as can be seen by the trailing Z. Timezone for Vancouver is specified as Standard Time: UTC -8 hours and Daylight Saving Time: UTC -7 hours. Lightning just displays the event mapped to your timezone. I think if you want a fixed time in a specific timezone you should configure your server to send the event in that timezone instead of UTC.
As extra data for this issue, if you create the event wholly within the standard time or daylight saving time periods, without crossing that boundary, the events seem to work OK. Here's the ICS file for a repeating set which does not cross the boundary:

BEGIN:VEVENT
DTSTART:20091114T230000Z
DTEND:20091115T000000Z
DTSTAMP:20091006T211910Z
UID:da26f255-52b8-4613-9e28-6c1d6de141ba
CREATED:20091006T211250Z
LAST-MODIFIED:20091006T211250Z
SUMMARY:repeat saturday
ORGANIZER;CN=Dewi Griffiths:mailto:dewi@brentwood.bc.ca
LOCATION:at home
CLASS:PUBLIC
STATUS:CONFIRMED
TRANSP:OPAQUE
RRULE:FREQ=WEEKLY;INTERVAL=1;BYDAY=SA;UNTIL=20100201T075959Z
END:VEVENT

they show correctly in both horde kronolith and in lightning. It shouldn't matter what timezone the events are sent as, the problem is that lightning is not taking into account the fact that it's crossing a time boundary between daylight saving and standard time when it's laying out it's views.
To clarify my comment from above: Lightning *does* take into account that the event is crossing a time boundary between daylight saving and standard time. UTC does not change during the daylight saving period because it does not observe daylight saving time. But your local timezone does (PST/PDT).

After creating the event in Lightning it is set to timezone America/Vancouver. You can check by enabling Options > Timezone in the New Event dialog. But your server seems to remove the timezone information because it sends back the event with times in UTC.

From your second example:

11 PM (UTC) -> 03 PM during Standard Time in Vancouver
11 PM (UTC) -> 04 PM during Daylight Saving Time in Vancouver

03 PM (America/Vancouver) -> 03 PM during Standard Time in Vancouver
03 PM (America/Vancouver) -> 03 PM during Daylight Saving Time in Vancouver
I agree with Stefan that there is no bug in Lightning involved. -> Resolving INVALID.

Dewi, feel free to re-open if you have additional information and want us to have another look.
Status: UNCONFIRMED → RESOLVED
Closed: 12 years ago
Resolution: --- → INVALID
I'm recommenting on this bug as I'm seeing more and more queries about this type of problem from people trying to use these fabulous open source products together. There clearly is some issue when using thunderbird as a client to horde fro ics subscription and I thought it might be advantageous for the horde coders and mozilla coders to be aware of the two bugs tracks I know of to try and converse with eachother about where the changes should be made to fix this issue.
Mozilla bug with exqamples is : https://bugzilla.mozilla.org/show_bug.cgi?id=520843
the horde bug is : http://bugs.horde.org/ticket/7156 
hopefully if the main development team from each project touch base, we'll get a reasonable solution. It's just a suggestion that I thought might help.
You need to log in before you can comment on or make changes to this bug.