Closed Bug 520977 Opened 12 years ago Closed 12 years ago

Dock icon doesn't reset when it gets to zero unread messages.

Categories

(MailNews Core :: Backend, defect)

All
macOS
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 3.0rc1

People

(Reporter: standard8, Assigned: standard8)

References

Details

(Keywords: regression)

Attachments

(1 file)

Attached patch The fixSplinter Review
Either:

a) Go through your unread messages one-by-one so the unread count gets to zero => Dock icon stays at one.

or:

b) Mark your last folder with unread messages as read => Dock icon stays at the count before unread.

Before bug 508001 this worked fine, however the patch removed the call before checking the unread total, and so currently we're just aborting BadgeDockIcon() early rather than aborting but calling RestoreDockIcon().
Flags: blocking-thunderbird3+
Attachment #405033 - Flags: superreview?(bienvenu)
Attachment #405033 - Flags: review?(david.humphrey)
Attachment #405033 - Flags: superreview?(bienvenu) → superreview+
Attachment #405033 - Flags: review?(david.humphrey) → review+
Comment on attachment 405033 [details] [diff] [review]
The fix

Indeed, thanks for catching/fixing this.  I had to change the logic, since the new drawing API doesn't require me to clear what was previously there, while the 10.4 method does, and I missed this case.
Checked in: http://hg.mozilla.org/comm-central/rev/c74ee52a58a3
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.