Custom field that should appear only when Resolution is FIXED is not displayed when you change the status to RESOLVED

RESOLVED FIXED in Bugzilla 3.4

Status

()

Bugzilla
Creating/Changing Bugs
RESOLVED FIXED
8 years ago
7 years ago

People

(Reporter: Liya, Assigned: Max Kanat-Alexander)

Tracking

3.4.2
Bugzilla 3.4
Dependency tree / graph
Bug Flags:
approval +
approval3.6 +
blocking3.6 +
approval3.4 +
blocking3.4.6 +

Details

Attachments

(1 attachment)

v1
2.29 KB, patch
Frédéric Buclin
: review+
Details | Diff | Splinter Review
(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.0.5) Gecko/2008120121 Firefox/3.0.5
Build Identifier: 3.4.2

I have a custom field that should appear only when Resolution is FIXED.
If I edit a bug in any "open" status, and change the status to RESOLVED, the resolution field appears while FIXED is the first value, so it's selected. This does not make my custom field be displayed on the page as expected. 
If I change Resolution to any other value and then back to FIXED, my custom field is displayed.

Reproducible: Always

Steps to Reproduce:
1.Define a custom field, set 'Field only appears when'=Resolution, 'is set to'=FIXED
2. Open existing bug in any open status (NEW/ASSIGNED/REOPENED)
3. Change status to RESOLVED
Actual Results:  
resolution field appears, FIXED is selected (the first value), but you custom field does not appear

Expected Results:  
Your custom field should appear in this case, the same like on change of the resolution field to FIXED
(Reporter)

Updated

8 years ago
Version: unspecified → 3.4.2

Comment 1

8 years ago
I can reproduce the problem. Probably should JS trigger this event.
Assignee: general → create-and-change
Severity: major → normal
Status: UNCONFIRMED → NEW
Component: Bugzilla-General → Creating/Changing Bugs
Ever confirmed: true
OS: Linux → All
Hardware: x86 → All
Target Milestone: --- → Bugzilla 3.4

Comment 2

8 years ago
OK, I couldn't understand why a custom field was not displayed despite the bug was marked as FIXED till I remembered this bug.
Flags: blocking3.4.5?
(Assignee)

Comment 3

8 years ago
If I finish this before the sec release, then it can be a blocker, otherwise it will have to wait for 3.4.6.
Flags: blocking3.4.5? → blocking3.4.5+

Updated

7 years ago
Flags: blocking3.4.5+ → blocking3.4.6+

Updated

7 years ago
Flags: blocking3.6+

Comment 4

7 years ago
there are a bunch of fields that don't use the custom field template so I can check this out. Did we test this across the board with all the built in fields?
(Assignee)

Updated

7 years ago
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 538211
(Assignee)

Comment 6

7 years ago
Okay, so it turns out that the bug that I duped this to was specifically a problem in enter_bug, so it couldn't possibly be related to this bug. Reopening.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
(Assignee)

Comment 7

7 years ago
Created attachment 425722 [details] [diff] [review]
v1

Okay, this fixes it. We fire onchange when we display or hide the resolution field, now, and when we hide it, we set it to an empty value so that the onchange works properly.
Assignee: create-and-change → mkanat
Status: REOPENED → ASSIGNED
Attachment #425722 - Flags: review?(guy.pyrzak)
Attachment #425722 - Flags: review?(LpSolit)
(Assignee)

Updated

7 years ago
Summary: Custom field that should appear only when Resolution is FIXED is not displayed when changing bug to RESOLVED FIXED → Custom field that should appear only when Resolution is FIXED is not displayed when you change the status to RESOLVED

Updated

7 years ago
Attachment #425722 - Flags: review?(LpSolit) → review+

Comment 8

7 years ago
Comment on attachment 425722 [details] [diff] [review]
v1

OK, this fixes the problem for me. r=LpSolit
(Assignee)

Updated

7 years ago
Flags: approval3.6+
Flags: approval3.4+
Flags: approval+
(Assignee)

Updated

7 years ago
Attachment #425722 - Flags: review?(guy.pyrzak)
(Assignee)

Comment 9

7 years ago
Committing to: bzr+ssh://bzr.mozilla.org/bugzilla/trunk/                       
modified js/field.js
Committed revision 6973.

Committing to: bzr+ssh://bzr.mozilla.org/bugzilla/3.6/                         
modified js/field.js
Committed revision 6967.

Committing to: bzr+ssh://mkanat%40bugzilla.org@bzr.mozilla.org/bugzilla/3.4/   
modified js/field.js
Committed revision 6722.
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago7 years ago
Resolution: --- → FIXED
(Assignee)

Updated

7 years ago
Blocks: 545277

Updated

7 years ago
Blocks: 548933

Updated

7 years ago
Duplicate of this bug: 575501
You need to log in before you can comment on or make changes to this bug.