/content/ unit tests fail on JavaScript 'strict' mode

RESOLVED FIXED in mozilla1.9.3a1

Status

()

Core
General
--
trivial
RESOLVED FIXED
9 years ago
9 years ago

People

(Reporter: Jae-Seong Lee-Russo, Assigned: Jae-Seong Lee-Russo)

Tracking

(Blocks: 1 bug)

Trunk
mozilla1.9.3a1
Points:
---
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(status1.9.2 final-fixed)

Details

Attachments

(1 attachment, 2 obsolete attachments)

(Assignee)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.3a1pre) Gecko/20091007 Minefield/3.7a1pre (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.3a1pre) Gecko/20091007 Minefield/3.7a1pre (.NET CLR 3.5.30729)

$ make -C content/test/ xpcshell-tests
make: Entering directory `/c/mozilla-build/mozilla-central/content/test'
c:/mozilla-build/python25/python2.5.exe -u /c/mozilla-build/mozilla-central/conf
ig/pythonpath.py \
          -I/c/mozilla-build/mozilla-central/build \
          /c/mozilla-build/mozilla-central/testing/xpcshell/runxpcshelltests.py
\
          --symbols-path=../../dist/crashreporter-symbols \
          ../../dist/bin/xpcshell \
          ../../_tests/xpcshell/test_content/unit
TEST-UNEXPECTED-FAIL | c:\mozilla-build\mozilla-central\_tests\xpcshell\test_con
tent\unit\test_isequalnode.js | test failed (with xpcshell return code: 0), see
following log:
  >>>>>>>
  TEST-INFO | (xpcshell/head.js) | test 1 pending
TEST-PASS | c:/mozilla-build/mozilla-central/_tests/xpcshell/test_content/unit/h
ead_content.js | [ParseFile : 76] true == true
TEST-UNEXPECTED-FAIL | (xpcshell/head.js) | TypeError: assignment to undeclared
variable fileStr

  <<<<<<<
TEST-UNEXPECTED-FAIL | c:\mozilla-build\mozilla-central\_tests\xpcshell\test_con
tent\unit\test_nodelist.js | test failed (with xpcshell return code: 0), see fol
lowing log:
  >>>>>>>
  TEST-INFO | (xpcshell/head.js) | test 1 pending
TEST-PASS | c:/mozilla-build/mozilla-central/_tests/xpcshell/test_content/unit/h
ead_content.js | [ParseFile : 76] true == true
TEST-UNEXPECTED-FAIL | (xpcshell/head.js) | TypeError: assignment to undeclared
variable fileStr

  <<<<<<<
TEST-UNEXPECTED-FAIL | c:\mozilla-build\mozilla-central\_tests\xpcshell\test_con
tent\unit\test_normalize.js | test failed (with xpcshell return code: 0), see fo
llowing log:
  >>>>>>>
  TEST-INFO | (xpcshell/head.js) | test 1 pending
TEST-PASS | c:/mozilla-build/mozilla-central/_tests/xpcshell/test_content/unit/h
ead_content.js | [ParseFile : 76] true == true
TEST-UNEXPECTED-FAIL | (xpcshell/head.js) | TypeError: assignment to undeclared
variable fileStr

  <<<<<<<
TEST-UNEXPECTED-FAIL | c:\mozilla-build\mozilla-central\_tests\xpcshell\test_con
tent\unit\test_range.js | test failed (with xpcshell return code: 0), see follow
ing log:
  >>>>>>>
  TEST-INFO | (xpcshell/head.js) | test 1 pending
TEST-PASS | c:/mozilla-build/mozilla-central/_tests/xpcshell/test_content/unit/t
est_range.js | [getParsedDocument : 219] true == true
TEST-PASS | c:/mozilla-build/mozilla-central/_tests/xpcshell/test_content/unit/t
est_range.js | [getParsedDocument : 220] true == true
TEST-PASS | c:/mozilla-build/mozilla-central/_tests/xpcshell/test_content/unit/t
est_range.js | [getParsedDocument : 221] true == true
TEST-PASS | c:/mozilla-build/mozilla-central/_tests/xpcshell/test_content/unit/t
est_range.js | [getParsedDocument : 222] true == true
TEST-UNEXPECTED-FAIL | (xpcshell/head.js) | TypeError: assignment to undeclared
variable i

  <<<<<<<
TEST-PASS | c:\mozilla-build\mozilla-central\_tests\xpcshell\test_content\unit\t
est_treewalker.js | test passed
TEST-PASS | c:\mozilla-build\mozilla-central\_tests\xpcshell\test_content\unit\t
est_xml_parser.js | test passed
TEST-PASS | c:\mozilla-build\mozilla-central\_tests\xpcshell\test_content\unit\t
est_xml_serializer.js | test passed
INFO | Result summary:
INFO | Passed: 3
INFO | Failed: 4
make: *** [xpcshell-tests] Error 1
make: Leaving directory `/c/mozilla-build/mozilla-central/content/test'

Reproducible: Always

Steps to Reproduce:
1. Run the xpcshell test with the '-S' option

Actual Results:  
Failed

Expected Results:  
Passed
(Assignee)

Comment 1

9 years ago
Created attachment 405187 [details] [diff] [review]
Fix the errors
(Assignee)

Updated

9 years ago
Attachment #405187 - Flags: review?(alex)
(Assignee)

Comment 2

9 years ago
Created attachment 405442 [details] [diff] [review]
Convert to UNIX newline
Attachment #405187 - Attachment is obsolete: true
Attachment #405442 - Flags: review?(alex)
Attachment #405187 - Flags: review?(alex)
(Assignee)

Updated

9 years ago
Blocks: 524781
(Assignee)

Updated

9 years ago
Attachment #405442 - Flags: review?(alex)
(Assignee)

Comment 3

9 years ago
Created attachment 409426 [details] [diff] [review]
/content/ unit tests fail on JS strict mode
Attachment #405442 - Attachment is obsolete: true
(Assignee)

Updated

9 years ago
Summary: xpcshell-tests fail with 'strict' & 'werror' turned on → /content/ unit tests fail on JavaScript 'strict' mode
(Assignee)

Updated

9 years ago
Attachment #409426 - Flags: review?(darin.moz)
Attachment #409426 - Flags: review?(Olli.Pettay)
(Assignee)

Comment 4

9 years ago
Comment on attachment 409426 [details] [diff] [review]
/content/ unit tests fail on JS strict mode

Darin Fisher, can you review head_content.js?

Olli Pettay, please review test_range.js & xtfComponent.js.
(Assignee)

Comment 5

9 years ago
Comment on attachment 409426 [details] [diff] [review]
/content/ unit tests fail on JS strict mode

I just found Darin no longer reviews.

Jeff, please review head_content.js.
Attachment #409426 - Flags: review?(darin.moz) → review?(jwalden+bmo)
Attachment #409426 - Flags: review?(Olli.Pettay) → review+

Updated

9 years ago
Attachment #409426 - Flags: review?(jwalden+bmo) → review+

Comment 6

9 years ago
http://hg.mozilla.org/mozilla-central/rev/c78659e72a1a

Thanks again!
Assignee: nobody → lusian
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.9.3a1
Flags: in-testsuite+
Keywords: checkin-needed
Whiteboard: [c-n: m-1.9.2, m-1.9.1]
Version: unspecified → Trunk
Pushed to 1.9.2: http://hg.mozilla.org/releases/mozilla-1.9.2/rev/bf15ba83f27c

Is this really clear to land on 1.9.2? No approval necessary?
status1.9.2: --- → final-fixed
Whiteboard: [c-n: m-1.9.2, m-1.9.1] → [c-n: m-1.9.1]
Clearing checkin keywords since these patches don't have 1.9.1 approval. Please request approval on the patches, and once granted, replace the checkin keyword.
Keywords: checkin-needed
Whiteboard: [c-n: m-1.9.1]
You need to log in before you can comment on or make changes to this bug.