Investigate showing a different first-run page

RESOLVED FIXED in seamonkey2.1a1

Status

SeaMonkey
Build Config
RESOLVED FIXED
8 years ago
7 years ago

People

(Reporter: Robert Kaiser, Assigned: Robert Kaiser)

Tracking

({fixed-seamonkey2.0})

Trunk
seamonkey2.1a1
x86
Linux
fixed-seamonkey2.0
Bug Flags:
wanted-seamonkey2.0 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Assignee)

Description

8 years ago
We should think about showing something different than our default homepage as first-run page, e.g. the relnotes.
Flags: wanted-seamonkey2.0?

Comment 1

8 years ago
Yes, would be good.
Flags: wanted-seamonkey2.0? → wanted-seamonkey2.0+
(Assignee)

Comment 2

8 years ago
Created attachment 405472 [details] [diff] [review]
Use relnotes instead

This makes us go to the relnotes on first run (redirects to the "get involved" page for nightlies).
I know this is a locales file, but it doesn't break anyone and if locales don't adapt to it, there's nothing bad that happens, so IMHO it should be OK even with a hard string freeze in place.
Assignee: nobody → kairo
Status: NEW → ASSIGNED
Attachment #405472 - Flags: review?(neil)
Attachment #405472 - Flags: approval-seamonkey2.0b2?
(Assignee)

Comment 3

8 years ago
Comment on attachment 405472 [details] [diff] [review]
Use relnotes instead

oops, want 2.0 approval, have no time machine around right now to push into beta.
Attachment #405472 - Flags: approval-seamonkey2.0b2? → approval-seamonkey2.0?

Updated

8 years ago
Attachment #405472 - Flags: review?(neil) → review+

Updated

8 years ago
Attachment #405472 - Flags: approval-seamonkey2.0? → approval-seamonkey2.0+
(Assignee)

Comment 4

8 years ago
Pushed as http://hg.mozilla.org/comm-central/rev/e636c7577a37
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Keywords: fixed-seamonkey2.0
Resolution: --- → FIXED
Target Milestone: --- → seamonkey2.1a1

Comment 5

8 years ago
Hmm, I am now directed to that exact URL on first-run (tried with Mozilla/5.0 (OS/2; U; Warp 4.5; en-US; rv:1.9.1.5pre) Gecko/20091014 SeaMonkey/2.0pre), with %VERSION% still as part of the URL! This leads to a 400 Bad Request. Should that not somehow get replaced by the actual version number? Or is there something server-side still missing?
(Assignee)

Comment 6

8 years ago
Uh, that doesn't sound good... are we not using the urlformatter like Firefox does?
(Assignee)

Comment 7

8 years ago
Right, we don't. reopening. I should have a fix to use the formatter here.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 8

8 years ago
Created attachment 406341 [details] [diff] [review]
use the formatter

This patch makes us use the formatter for this one, I tested it with a profile that correctly ended up with the following output:
Document http://www.seamonkey-project.org/releases/seamonkey2.0pre/ loaded successfully
(and I was correctly redirected to the get-involved page)
Attachment #406341 - Flags: review?(neil)
Attachment #406341 - Flags: approval-seamonkey2.0?

Updated

8 years ago
Attachment #406341 - Flags: review?(neil) → review+

Updated

8 years ago
Attachment #406341 - Flags: approval-seamonkey2.0? → approval-seamonkey2.0+
(Assignee)

Comment 9

8 years ago
Thanks for the fast r/a, pushed as http://hg.mozilla.org/comm-central/rev/9db84f526a83
Status: REOPENED → RESOLVED
Last Resolved: 8 years ago8 years ago
Resolution: --- → FIXED
(Assignee)

Updated

7 years ago
Duplicate of this bug: 144706
You need to log in before you can comment on or make changes to this bug.