Closed Bug 521498 Opened 10 years ago Closed 10 years ago

Page not found error on clicking "view all" for Discussions under Firefox group

Categories

(Participation Infrastructure :: Phonebook, defect, major)

x86
All
defect
Not set
major

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: krupa.mozbugs, Unassigned)

References

()

Details

steps to reproduce:
1.Log into your CRM account
2.Become a member of the group-"Firefox"
3.Click on "view all" link under Discussions

observed behavior:
Page not found error on clicking "view all" for Discussions under Firefox group

screenshot: http://screencast.com/t/fFyplwPV8
* This was part access issue and menu issue
* The way the og_forum module was building the menu item for node/XX/forum, was not done right in that it just kind of failed if access was not allowed or the right forum was not found.
* Also, it was attempting to do access check for forums, which is not the right place to do it.
* I created a menu_alter in the mozcrm.module that actually ensures that the redirect/alias happens and that access is determined by the forum and og, not from arbitrary logic.
* Please note that access to that forum is a separate issue, imo
Are you calling this issue fixed?
This works for me now... so yes, this looked r.fixed.
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
yeah, verified on https://mozillians.stage.mozilla.com/forum/424
Status: RESOLVED → VERIFIED
Component: mozillians.org → Phonebook
Product: Websites → Community Tools
QA Contact: mozillians-org → phonebook
Version: unspecified → other
You need to log in before you can comment on or make changes to this bug.