Uncaught Exception NS_ERROR_FAILURE JS frame :: chrome://navigator/content/tabbrowser.xml :: line 2364

RESOLVED FIXED

Status

SeaMonkey
Session Restore
RESOLVED FIXED
9 years ago
8 years ago

People

(Reporter: Hb, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.5pre) Gecko/20091011 Lightning/1.0pre SeaMonkey/2.0pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.5pre) Gecko/20091011 Lightning/1.0pre SeaMonkey/2.0pre AND Mozilla/5.0 (X11; U; Linux i686; de; rv:1.9.1.5pre) Gecko/20091008 Lightning/1.0pre SeaMonkey/2.0pre

Closing the MailNews window throws an uncaught exception, even in new profile.

Reproducible: Always

Steps to Reproduce:
1. Close the MailNews window
Actual Results:  
Error console shows:
Error: uncaught exception: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIObserverService.removeObserver]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: chrome://navigator/content/tabbrowser.xml ::  :: line 2364"  data: no]
[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.1.4) Gecko/20091007 SeaMonkey/2.0] (release, rc1) (W2Ksp4)

Code is
{
2364           os.removeObserver(this, "browser:purge-session-history");
}

Obviously, Session Restore is not yet implemented for MailNews...
Component: MailNews: Message Display → Session Restore
Flags: wanted-seamonkey2.0?
QA Contact: message-display → session.restore
Version: unspecified → Trunk

Comment 2

9 years ago
But if we do call the dtor, we should have called the ctor as well, so must be more going wrong here...

Comment 3

9 years ago
Caused by bug 521803, which hinders the observer registration in the ctor.
Depends on: 521803
Flags: wanted-seamonkey2.0?
[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.3a1pre) Gecko/20100131 SeaMonkey/2.1a1pre] (home, optim default) (W2Ksp4)

(Bug still there.)
It happens during mochitest-chrome test_idcheck.xul too. (line is 2380 now).

Comment 5

8 years ago
Is this bug about sessionstore ? Seems wrong component ...

Comment 6

8 years ago
Does it still happen? Does it belong in a different component?
(In reply to comment #6)
> Does it still happen?

Yes, see bug 613823 comment 1, for example.
This bug just needs bug 521803 to be fixed...
{
2688           os.removeObserver(this, "browser:purge-session-history");
2689           this.savedBrowsers.forEach(function(aTabData) {
2690             delete aTabData._tab;
2691             delete aTabData._browser;
2692             delete aTabData._history;
2693           });
2694         ]]>
2695       </destructor>
}

Iiuc, not executing the forEach loop might be causing memory leaks and/or later logic errors...
Would that make you reconsider wanted/blocking flags for bug 521803?

Updated

8 years ago
Depends on: 628918
No longer depends on: 521803

Comment 9

8 years ago
Now that bug 628918 has landed these errors should go away. Serge?

Comment 10

8 years ago
Fixed by bug 628918.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.