Closed Bug 521867 Opened 12 years ago Closed 12 years ago

Deleting/Detach attachment issue with imap (use INTERNALDATE in append command)

Categories

(MailNews Core :: Networking: IMAP, defect)

1.9.1 Branch
x86
All
defect
Not set
major

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 3.1a1

People

(Reporter: el.cameleon.1, Assigned: Bienvenu)

Details

(Whiteboard: [has protocol logs])

Attachments

(2 files)

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; fr; rv:1.9.0.14) Gecko/2009090216 Ubuntu/9.04 (jaunty) Firefox/3.0.14
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; fr; rv:1.9.1.4pre) Gecko/20090915 Lightning/1.0pre Thunderbird/3.0b4

- if I detach an attachment from an email, everything seems to work OK in Thunderbird.
- but when I go on the server, I see that a new message without the attachment has been downloaded with the current date (and not the date of the original mail)!!!

I use imap from laposte.net (french provider), but this bug as also been confirmed with gmail.

Reproducible: Always

Steps to Reproduce:
1. Choose an old mail with an attachment
2 [review]. Detach or delete this attachment
Actual Results:  
First, everything seems to work OK in Thunderbird.
But when I close TB and go on the server, I see that a new message without the attachment has been downloaded with the current date (and not the date of the original mail)!!!

Expected Results:  
Same behaviour than in TB2, where the email keep is original date.

Forum threads:
http://forums.mozillazine.org/viewtopic.php?f=31&t=1530355
http://www.geckozone.org/forum/viewtopic.php?f=30&t=78016&start=0&sid=5e966a44a32c6e153d786564d0ebbfb2
Caméléon , could you provide us a imap log reproducing the issue ? 
(how to log is explained at https://wiki.mozilla.org/MailNews:Logging )

What happens when you reopen Thunderbird after that with regards to the message you tried to detach the attachment from ?
Component: General → Networking: IMAP
Product: Thunderbird → MailNews Core
QA Contact: general → networking.imap
Summary: [REGRESSION] Deleting/Detach attachment issue with imap → Deleting/Detach attachment issue with imap
Whiteboard: regression
Version: unspecified → 1.9.1 Branch
Hi,
I have just done the job, I delete an attachment called "Delphi Les Echos 3_2_2009.JPG" from a message called "Delphi".

The result seems ok in thunderbird, because the message keep its original date.
But it is not the case on the server, it has been downloaded with the current date.

I attach the log file.
Keywords: regression
Whiteboard: regression → [has protocol logs]
The only way to detach an attachment in imap is to create a new copy of the message without the attachment. The imap protocol does not allow for editing of a message on the server.
Keywords: regression
However, it was working with TB2, so I think it should be possible to return to the original behavior which was more logical.
2.0 might have set the date in the append command...
but it didn't, from what I can see running 2.0. This can be fixed, however.
Attached patch proposed fixSplinter Review
This should fix it.
Assignee: nobody → bienvenu
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Attachment #406525 - Flags: superreview?(neil)
Attachment #406525 - Flags: review?(neil)
Comment on attachment 406525 [details] [diff] [review]
proposed fix

I gave up trying to find UI for the INTERNALDATE (at least, using either GMail or NTMail) so I had to resort to telnet ;-)
Attachment #406525 - Flags: superreview?(neil)
Attachment #406525 - Flags: superreview+
Attachment #406525 - Flags: review?(neil)
Attachment #406525 - Flags: review+
fixed on trunk, fix will be in 3.1
Status: ASSIGNED → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 3.1a1
Summary: Deleting/Detach attachment issue with imap → Deleting/Detach attachment issue with imap (use INTERNALDATE in append command)
You need to log in before you can comment on or make changes to this bug.