Can't print a news message

VERIFIED FIXED

Status

P2
normal
VERIFIED FIXED
18 years ago
14 years ago

People

(Reporter: nbaca, Assigned: rhp)

Tracking

Trunk
All
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta3+] Fix in hand)

Attachments

(2 attachments)

(Reporter)

Description

18 years ago
Build 2000-09-11-08M18: NT4, Linux 6.0, Mac 9.04

Overview: Each operating system has slightly different symptoms but the results 
are the same. The print dialog does not appear and the news message is not 
printed.

Steps to reproduce:
1. Select a news message from the thread pane
2. Select File|Print

Actual Results:

- NT4: The Print dialog does not appear, instead a print icon is minimized at 
the bottom of the windows taskbar. Clicking on it does nothing. I can close the 
icon but no option to print the news message.

- Linux: Only the extra window appears with the contents of the message, the 
Print dialog never appears.

- Mac: Focus from the 3-pane goes away and nothing else happens. I can reselect 
the 3-pane window and focus is returned but the print dialog never appears.

Expected Results: The print dialog should appear.

Additional Information:
- Printing a mail message is OK.
(Reporter)

Comment 1

18 years ago
Nominating for beta3. You should be able to print a news message.
Keywords: nsbeta3

Comment 2

18 years ago
reassigning to rhp.
Assignee: putterman → rhp
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → M19
(Assignee)

Comment 3

18 years ago
Agreed. This is bad. Will investigate.

- rhp

Comment 4

18 years ago
assign it to myself.
QA Contact: esther → fenella

Comment 5

18 years ago
marking nsbeta3+ per mail triage.
Priority: P3 → P2
Whiteboard: [nsbeta3+]
(Assignee)

Comment 6

18 years ago
Hi guys,
Did something change with rendering news messages that I now don't get the 
nsIDocumentLoaderObserver listener events that I get with mail messages?

- rhp
(Assignee)

Comment 7

18 years ago
Per Seth's recommendation, I am copying David and Scott:

Guys...could any changes you've made recently cause me to stop getting listener 
events on news URL's?

- rhp

Comment 8

18 years ago
I don't know if this would cause it, but my change to nsNNTPProtocol.cpp 1.200
is using the url for something it wasn't used for before.
(Assignee)

Comment 9

18 years ago
Ok, I backed out the small change from nsNNTPProtocol.cpp 1.200 and it still is 
broken.

- rhp

Comment 10

18 years ago
what listener events do you mean, Rich? Are you looking for OnStopRequest in
particular?
(Assignee)

Comment 11

18 years ago
OnEndDocumentLoad in particular.

- rhp
(Assignee)

Comment 12

18 years ago
Ok, this is failing deep in the guts of NNTP. Here is what is happening:

nsresult nsNNTPProtocol::CleanupAfterRunningUrl()
{ 
  if (m_loadGroup)
   m_loadGroup->RemoveChannel(NS_STATIC_CAST(nsIChannel *, this), nsnull, 
NS_OK, nsnull);

is called and the RemoveChannel() call then fails at the following location:

    //
    // Remove the channel from the group.  If this fails, it means that
    // the channel was *not* in the group so do not update the foreground
    // count or it will get messed up...
    //
    //
    // XXX this method incorrectly returns a bool
    //
    rv = mChannels->RemoveElement(channel) ? NS_OK : NS_ERROR_FAILURE;
    if (NS_FAILED(rv)) {
        PR_LOG(gLoadGroupLog, PR_LOG_ERROR,
               ("LOADGROUP [%x]: Unable to remove channel %x. Not in group!\n",
                this, channel));
        return rv;
    }


Because of this failure, the OnStopRequest() for my webshell is never called 
and I never see the end of any operation....so I never prompt to print.

Any help!

- rhp

Comment 13

18 years ago
Created attachment 14942 [details] [diff] [review]
proposed fix

Comment 14

18 years ago
Scott, does this look OK? We need the rest of what nsMsgProtocol::OnStartRequest
does, including the add load group, not just the listener stuff.

Comment 15

18 years ago
Yeah that looks okay to me.

Comment 16

18 years ago
PDT believes that this should be a P3. Resetting priorities.  Workaround possible
Priority: P2 → P3
Whiteboard: [nsbeta3+] → [nsbeta3+][pdtp3]

Comment 17

18 years ago
What's the workaround? writing out your news message on a piece of paper?
Whiteboard: [nsbeta3+][pdtp3]

Comment 18

18 years ago
:-)

Isn't the workaround to move/copy/save the news message to a regular mail folder
and then print from there?  I doubt that anyone not a developer would figure
that out before switching to another product...

Comment 19

18 years ago
Adding back nsbeta3+ and putting back p2. I think this will get it back on PDT's
radar which is what I think bienvenu was trying to do. I disagree with PDT's
assessment also though this probably works if you copy it to a mail folder.
However, writing it out on a piece of paper does sound like a good idea. It
might be faster :)
Priority: P3 → P2
Whiteboard: [nsbeta3+]

Comment 20

18 years ago
I guess you could mail yourself the news message and print it that way :-) Maybe
we should have a contest to see who can come up with the ungainliest workaround.
Whiteboard: [nsbeta3+] → [nsbeta3+] Fix in hand

Comment 21

18 years ago
Created attachment 14974 [details] [diff] [review]
proposed fix

Comment 22

18 years ago
Scott and/or Seth, can you look at the last patch? In addition to adding the
OnStopRequest call, I had to change the fix I had for the copying of multiple
news messages to be more like the code was before I fixed those memory leaks -
basically, now I check if the OnStopRequest evilly caused us to run another url
(by using m_connectionBusy) and if so, I don't free up the url info.
(Assignee)

Comment 23

18 years ago
I've run and reviewed this and it works/looks good to me.

- rhp

Comment 24

18 years ago
Copying multiple news messages still works, and we're not leaking urls...
I thought the right way to print was to take a screen shot of the app, and print
that.

Comment 26

18 years ago
hmm, that's possible, but I think it would be better to use one of those web
email fax services to fax a copy of the news message to yourself.

Comment 27

18 years ago
David your latest set of changes look good. feel free to use me as the reviewer.
(Assignee)

Comment 28

18 years ago
Bug squashed!

- rhp
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 29

18 years ago
Mac (2000-09-21-04 M18)
Win32 (2000-09-21-09 M18)
Printing news works fine in these platforms. Will try Linux too.

Comment 30

18 years ago
Linux (2000-09-20-08 M18)
Linux printing news works fine too.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.