Closed Bug 522114 Opened 13 years ago Closed 13 years ago

can only play the first few minutes of a video

Categories

(Core :: Audio/Video, defect, P2)

1.9.2 Branch
x86
Windows NT
defect

Tracking

()

RESOLVED FIXED
Tracking Status
status1.9.2 --- beta2-fixed

People

(Reporter: blizzard, Assigned: roc)

References

()

Details

(Keywords: regression)

Attachments

(2 files)

I think that we're not able to play past the end of the media cache.  On the video above we play the first five minutes of the video and then it stops and shows itself at the end of the video.

(The video is 15 minutes long, is about 146MB in size and it stops at about 5 minutes.  I think our default media cache is 50MB?)

Works OK in Firefox 3.5.
Flags: blocking1.9.2?
Two problems here:

The media cache doesn't seem to be releasing blocks once they're played, so once the cache fills we continuously suspend and resume the stream to allow playback to continue.

When the video ends prematurely, we've just resumed the stream.  We get one OnDataAvailable callback on the stream, then an OnStopRequest which causes the media cache to treat the stream as ended.
Assignee: nobody → roc
Flags: blocking1.9.2? → blocking1.9.2+
Stupid bug made us think we were always pinned.

To test this properly we need support for 'buffered'.
Attachment #406172 - Flags: review?(chris.double)
Attached patch fix resumingSplinter Review
We should reopen if the connection closes after a resume, even if it appeared to close normally.

We still end prematurely if the connection is not seekable and we suspend, then the server closes our connection. That's just too bad, there's really no way to handle these scenarios. Fortunately with the pinning bug fixed we won't suspend nearly as much.
Attachment #406173 - Flags: review?(kinetik)
Whiteboard: [needs review]
Attachment #406172 - Flags: review?(chris.double) → review+
Attachment #406173 - Flags: review?(kinetik) → review+
Whiteboard: [needs review] → [needs landing]
Priority: -- → P2
Checked in:
http://hg.mozilla.org/mozilla-central/rev/d02342520b16
http://hg.mozilla.org/mozilla-central/rev/9de290615b21

Disabled test_resume because it's failing sometimes:
http://hg.mozilla.org/mozilla-central/rev/50796c65175d
Status: NEW → RESOLVED
Closed: 13 years ago
Flags: in-testsuite?
Resolution: --- → FIXED
Whiteboard: [needs landing] → [needs 192 landing]
You need to log in before you can comment on or make changes to this bug.