Closed Bug 522201 Opened 10 years ago Closed 10 years ago

WebGL gl.clear doesn't update canvas if nothing else is drawn

Categories

(Core :: Canvas: 2D, enhancement)

x86_64
Linux
enhancement
Not set

Tracking

()

RESOLVED FIXED

People

(Reporter: 00003b, Unassigned)

Details

Attachments

(2 files)

User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.1.3) Gecko/20090910 Ubuntu/9.04 (jaunty) Shiretoko/3.5.3
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.3a1pre) Gecko/20091013 Minefield/3.7a1pre

calling cl.clear without any other drawing doesn't update the contents of the canvas drawn on the web page

Reproducible: Always

Steps to Reproduce:
1. view attached test case in webgl enabled browser
2. move mouse over webgl canvas area
3.
Actual Results:  
canvas doesn't update from mousemove events, which call gl.Clear, but do update when from mousedown events, which calls drawElements. The mousemove events sometimes do have an effect right after a mousedown event though.

Expected Results:  
canvas is cleared and changes color based on mouse position when mouse is moved over canvas area

I've listed it as 'enhancement' severity, since there isn't a spec available to say which behavior is correct, and it is easy to work around anyway, either by making a 0 element draw call, or just using a quad to clear the screen in the first place. At least 1 other person in addition to me was confused by this when first starting out though, since it is an obvious first thing to try, and seems like it should work.
Attached file test case
Attachment #408806 - Flags: review?(vladimir)
http://hg.mozilla.org/mozilla-central/rev/e609c57a916d
Status: UNCONFIRMED → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.