Huge memory/processor usage when firefox is not closed for 1-2 days or more

RESOLVED INVALID

Status

()

Firefox
General
--
major
RESOLVED INVALID
8 years ago
8 years ago

People

(Reporter: Sunando, Unassigned)

Tracking

3.5 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 5.1; Trident/4.0; .NET CLR 2.0.50727; .NET CLR 3.0.04506.30; .NET CLR 3.0.04506.648; .NET CLR 3.5.21022; InfoPath.2; .NET CLR 1.1.4322; MS-RTC LM 8; .NET CLR 3.0.4506.2152; .NET CLR 3.5.30729)
Build Identifier: 

Observing huge memory usage for firefox.

Machine setup
Win XP

Have installed the addons IETab, Ad Block Plus, Download manager, Download status bar, video download helper.

When the firefox instance is started and some 8-10 tabs are kept open for a day or 2 we see huge memory consumptions. Maybe there is a leak in the addons (I have a doubt on IETab ) I observed this after I have installed IETab addon. 

Reproducible: Always

Steps to Reproduce:
1.Kepp the 1/2 fireforx instance open with 8-10 tabs.
2.Keep the machine idle for a day or two
3.See that memory usage is huge and firefax has slowed down a lot.
Actual Results:  
Firefox becomes extremely slow and when you go to taskbar you can see arnd half the processor is used by firefox and around 500MB is used by firefox.exe

Expected Results:  
Memory/processor usage should be under control
(Reporter)

Comment 1

8 years ago
Created attachment 406187 [details]
Image of memory/peocessor usage

Image of memory/peocessor usage
(Reporter)

Comment 2

8 years ago
Also cannot close the instance.. Need to kill the firefox.exe instance from task manager.

Version info:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3 (.NET CLR 3.5.30729)
If this happened after you installed IEtab, it is most likely a problem with them. I suggest you talk to them.
Severity: critical → major
Please run Firefox without addons, for example in the Firefox safemode (http://support.mozilla.com/en-US/kb/Safe+Mode ).

DO you get the same issue without addons ?
(Reporter)

Comment 5

8 years ago
Didnt observe when firefox is used in safe mode. Kept 2 instance with each 8 tabs open.
The safemode is Firefox without addons and Themes.
I know it's difficult if you get such issues only after running Firefox a long time but all you can do is to disable the installed addons (Tools/addons) one by one to find the one that is causing this. Disable 50% of the addons and test, if you get the error again it's on of the enabled addons and if not it's in the other half of the addons.....

Comment 7

8 years ago
sounds like invalid, due to addon.
please reopen if you feel otherwise.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INVALID
Version: unspecified → 3.5 Branch
You need to log in before you can comment on or make changes to this bug.