Crash [@ nsImapMailFolder::ParseAdoptedMsgLine(char const*, unsigned int, int, nsIImapUrl*)]

VERIFIED FIXED in Thunderbird 3.0rc1

Status

MailNews Core
Networking: IMAP
--
critical
VERIFIED FIXED
8 years ago
6 years ago

People

(Reporter: Usul, Assigned: Bienvenu)

Tracking

({crash, fixed-seamonkey2.0.1, regression})

1.9.1 Branch
Thunderbird 3.0rc1
crash, fixed-seamonkey2.0.1, regression

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
http://crash-stats.mozilla.com/report/index/0a083c9a-dbdf-4a1f-ba87-a82d02091007
Crashed while shutting down to upgrade Lightning to latest snapshot.

The stack is small and just looks bad : 
0 thunderbird.exe nsImapMailFolder::ParseAdoptedMsgLine mailnews/imap/src/nsImapMailFolder.cpp:4409
1 xpcom_core.dll NS_InvokeByIndex_P xpcom/reflect/xptcall/src/md/win32/xptcinvoke.cpp:101
2 nspr4.dll PR_Unlock nsprpub/pr/src/threads/combined/prulock.c:347
3 xpcom_core.dll nsProxyObjectCallInfo::Run xpcom/proxy/src/nsProxyEvent.cpp:181
4 xpcom_core.dll nsThread::ProcessNextEvent xpcom/threads/nsThread.cpp:521
Possibly a regression because it first appears 20091001032040 build.
It's even possible it's gone - because crash was happening steadily with every daily build until last crash with build 20091009032155 on 2009-10-12 00:00 - suddenly stopped
Severity: normal → critical
Keywords: regression
(Assignee)

Comment 2

8 years ago
Created attachment 406228 [details] [diff] [review]
possible fix

depending on how far we are into shutdown, we may not be able to get the message header, so we should really check the rv.
Assignee: nobody → bienvenu
Status: NEW → ASSIGNED
Attachment #406228 - Flags: superreview?(bugzilla)
Attachment #406228 - Flags: review?(bugzilla)
(Assignee)

Comment 3

8 years ago
I suspect this has to do with receiving imap headers at shutdown time
Attachment #406228 - Flags: superreview?(bugzilla)
Attachment #406228 - Flags: superreview+
Attachment #406228 - Flags: review?(bugzilla)
Attachment #406228 - Flags: review+
(Assignee)

Comment 4

8 years ago
fix checked in, a=me, since it's a top crash.
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 3.0rc1

Updated

8 years ago
Summary: Crash @[nsImapMailFolder::ParseAdoptedMsgLine(char const*, unsigned int, int, nsIImapUrl*)] → Crash [@ nsImapMailFolder::ParseAdoptedMsgLine(char const*, unsigned int, int, nsIImapUrl*)]
last build we see crash is 2009101500
v.fixed
Status: RESOLVED → VERIFIED

Updated

8 years ago
Keywords: fixed-seamonkey2.0.1
Crash Signature: [@ nsImapMailFolder::ParseAdoptedMsgLine(char const*, unsigned int, int, nsIImapUrl*)]
You need to log in before you can comment on or make changes to this bug.