Closed Bug 522236 Opened 10 years ago Closed 9 years ago

Signup to event completed with "invalid data" error

Categories

(Participation Infrastructure :: Phonebook, defect)

x86
Linux
defect
Not set

Tracking

(Not tracked)

VERIFIED WONTFIX

People

(Reporter: Milos, Unassigned)

References

()

Details

Steps to reproduce:

1. Open http://dev.trellon.org/mozcrm/crm/event/mozilla-test-event
(I was logged in as administrator)
2. Click sign up for this event at the bottom of the page
3. Leave all fields as they are and complete the signup.

Output:

Mozilla test event
Signup to Mozilla test event confirmed. You will receive a confirmation email shortly which contains further information about this Event. You will receive a reminder email 1 day before the Event.
Error loading activity: Invalid Data

Expected:

No error after finished sign-up
I tried to reproduce this error but was unable to.  I attempted with multiple different users.

* Can you try again?
* What specific user was this with?
(In reply to comment #1)
> I tried to reproduce this error but was unable to.  I attempted with multiple
> different users.
> 
> * Can you try again?
> * What specific user was this with?

I have tried, but it looks like I can't reproduce it. I have made that event and also got that error message while logged in as Milos-Testing.

Can you give a list of possible causes for "Error loading activity: Invalid Data
"?
Alan:  Not sure if this is related and/or due to some old code left behind by the previous dev firm, but I think when Milos signed up for this event, I got an email from a chicagotech address.  Just something to look into.

But glad to hear this is not reproducible.
Reasons for error:

* Looks like it was caused from the custom module: civisignup, which integrates the Drupal signup module and CiviCRM
* The specific error is a relay of a CiviCRM error, specifically in getting activities for a contact.
* "Invalid Data" is a really vague error message and not that helpful.  I think going deeper into CiviCRM is not worth the time, since CiviCRM is a very different beast than Drupal.  If problem persists, it would be worth looking into.
This works for me at https://mozillians.stage.mozilla.com/node/244/signups -> Fixed
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
(In reply to comment #5)
> This works for me at https://mozillians.stage.mozilla.com/node/244/signups ->
> Fixed

Sorry, I can still reproduce the issue. 

Signup info:
Your signup information
First Name:	test
Last Name:	test
Phone:	019377626263525
Email:	bla@bla.com
Where are you traveling from to attend this event?:	because it's cool!
Why are you attending?:	Why not?
I am interested in learning about future events like this:	No
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Tried with:

First Name:	test
Last Name:	test
Phone:	019377626263525
Email:	blah@blah.com
Where are you traveling from to attend this event?:	because it's cool!
Why are you attending?:	why not?
I am interested in learning about future events like this:	No

And still cant reproduce. Could you post a screenshot ?
I can reproduce it too. Here's the screenshot:

http://milos.mozilla-srbija.org/mozwebqa/invalidata.png
based on comment #4, i am not too worried about this one.  

as long as the event is created as expected and the data is all there (at least the data that matters), we can live with it until next version.
Status: REOPENED → RESOLVED
Closed: 10 years ago9 years ago
Resolution: --- → WONTFIX
Component: mozillians.org → Phonebook
Product: Websites → Community Tools
QA Contact: mozillians-org → phonebook
Version: unspecified → other
Bumping to verified wontfix due to the passage of time. This refers to a version of the app that is no longer supported.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.