Closed Bug 522282 Opened 10 years ago Closed 10 years ago

Toolbar icons - Use the N900 theme or use our own variant

Categories

(Firefox for Android Graveyard :: General, defect)

ARM
Maemo
defect
Not set

Tracking

(fennec1.0+)

VERIFIED FIXED
fennec1.0
Tracking Status
fennec 1.0+ ---

People

(Reporter: mfinkle, Assigned: mfinkle)

References

Details

Attachments

(2 files, 1 obsolete file)

N900 ships with several themes and more can be added. We currently have the task switcher, close and back images hard coded. We could try to pull the correct images from the theme itself so we adapt when the theme changes.

Or we could go the route the N900 Maps application uses: Custom images that fit the app theme and not use the current theme.
tracking-fennec: --- → ?
Duplicate of this bug: 527640
tracking-fennec: ? → 1.0+
We have decided to create our own variant of the task bar icons for Fennec 1.0

Assigning to Madhava until we get a designer to work on it.
Assignee: nobody → madhava
putting some thoughts down about this --

- we don't want them to blend in with fennec too much -- I'm relying on them looking more like the system than our own controls to provide cues about what they're for (i.e. NOT browser controls)
- the forms should remain the same as for the rest of the system, so all we have to work with is the interior spaces (color, gradients)
Attached file custom OS button icons (obsolete) —
Assignee: madhava → mark.finkle
Attached patch patchSplinter Review
Attachment #415320 - Flags: review?(gavin.sharp)
Attachment #415320 - Flags: review?(gavin.sharp) → review+
pushed:
https://hg.mozilla.org/mobile-browser/rev/4fd882c65431
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Target Milestone: --- → Post-B5
verified FIXED on builds:

Mozilla/5.0 (X11; U; Linux armv7l; Nokia N900; en-US; rv:1.9.2b5pre) Gecko/20091201 Firefox/3.6b5pre Fennec/1.0b6pre

and

Mozilla/5.0 (X11; U; Linux armv6l; Nokia N8xx; en-US; rv:1.9.3a1pre) Gecko/20091201 Firefox/3.7a1pre Fennec/1.0b5
Status: RESOLVED → VERIFIED
Component: Linux/Maemo → General
OS: Linux → Linux (embedded)
QA Contact: maemo-linux → general
Hardware: x86 → ARM
You need to log in before you can comment on or make changes to this bug.