If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

window handle returned by open/openDialog does not provide a handle to a valid js context.

VERIFIED INVALID

Status

()

Core
DOM: Core & HTML
P3
normal
VERIFIED INVALID
17 years ago
17 years ago

People

(Reporter: Ben Goodger (use ben at mozilla dot org for email), Assigned: vidur (gone))

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

Now, I'm not sure whether or not this is supposed to work or not, but it seems 
nice and useful:

the handle returned by open()/openDialog() is of type [object Window], but does 
not allow access to the functions and variables defined in the global scope of 
the opened window. 

Steps to reproduce:
1) Attached are two files, test1.html and test2.html. Place both in the same 
folder, and load test1.html.
2) test1.html opens a new window when the form button is clicked, and attempts 
to access a global variable in that new window document called someString by 
hWindow.someString. This returns 'undefined'. The results are displayed in an 
alert box.

Vidur, jst said this could have been a side effect of the split of DOMWindow. He 
said that either you or he would be best to look at this, if it is indeed a bug 
(as I said, not sure if this is supposed to work, but it seems useful).
Created attachment 14475 [details]
first test html file
Created attachment 14476 [details]
second test html file
ok, jst tried this, and after discussion we decided this is not a bug. 

resolving invalid. sorry for the spam!
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → INVALID

Comment 4

17 years ago
Not a bug. Mozilla handles it correctly. Marking verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.