Multiple Proxy auth windows are opened on session restore, one is off screen on Mac

RESOLVED DUPLICATE of bug 356097

Status

()

RESOLVED DUPLICATE of bug 356097
9 years ago
9 years ago

People

(Reporter: brett, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3

Problem:


Our workplace proxy requires authentication to log in or log on, both username and password, in order to access beyond our intranet.

If the browser is configured to username and password are set up in preferences to "Use system proxy settings", and the operating system has been set up with the proxy's host, port, username and password, Firefox insists on prompting the user for the username and password. 

When opening Firefox with an internet page as a homepage, or pages from a previous session reopening, along with an add-on trying to use the internet, Firefox may open several proxy authentication windows, one for each page, and one for each instance of Flash Player on those pages, and another modeless, unattached to a browser auth window, which I'm guessing is an auth request encountered an add-on.

Sometimes this modeless window will float with a window bar in the middle of a screen, but annoyingly sometimes this window will not have a window bar and be floating off-screen.

Closing all normally visible browser windows (without quitting) will leave this modeless window open, and will cause all normal methods of re-opening windows (cmd+n, cmd+t, clicking the dock icon) to not work. The menu bar will also only show the Firefox menu, not any of the normal "File, edit, view, history, etc" entries to be visible. This is because that modeless window is off screen with focus. 

Workaround:
Using Mac OS X's Exposé feature, we can see this window. It usually comes in from off the top-left corner of the main monitor (the one with the menubar/dock). (This problem is not limited to users with multiple monitors, and affects users with single monitor setups too.) 

Using Exposé we can give this modeless window focus. It will animate back off the screen, but it will have keyboard focus, so pressing return or esc will invoke the OK or Cancel button respectively. At this point, the problem has been successfully worked around

Opinion:
When available from the operating system, Firefox should use the authentication credentials provided. If these credentials fail, then it should prompt the user. Firefox should only ask for this proxy authentication once. It should not create multiple modal/modeless windows asking for the same username and password.

Reproducible: Sometimes

Steps to Reproduce:
(Happens on some computers, always)

1. Install an extension that requires internet access at launch, such as Xmarks or Personas.
2. Configure firefox to use the system proxy, which is set up with proxy host, port, username and password
3. open several pages that require proxy authentication to view. Try pages without flash and ones with several flash widgets on them.
4. quit firefox, saving open pages in session to be opened on launch.
5. Restart firefox
Actual Results:  
Firefox will open several proxy authentication windows empty of the system authentication details, one for each page, and one for each instance of Flash Player on those pages, and another modeless, unattached to a browser auth window, which I'm guessing is an auth request encountered an add-on, which may be off screen, and only be viewed using Exposé

Expected Results:  
Use system proxy authentication details from system preferences. Authenticate only once, and not require multiple authentications. No off-screen proxy authentication windows causing problems when application is closed.

Running Xmarks, Firebug, Web Developer Toolbar, Delicious Bookmarks, Personas, Stylish, Greasemonkey (only for Gmail)
(Reporter)

Comment 1

9 years ago
This bug has been around since Firefox 2 by the way.

Comment 2

9 years ago
fixed in 3.6
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 356097
You need to log in before you can comment on or make changes to this bug.