Closed Bug 522506 Opened 10 years ago Closed 10 years ago

aero peek shows generic thumbnails instead of thumbnails/previews

Categories

(Firefox :: Shell Integration, defect)

3.6 Branch
x86
Windows 7
defect
Not set

Tracking

()

RESOLVED INVALID

People

(Reporter: jbecerra, Unassigned)

References

Details

Attachments

(7 files)

When I open several tabs, say, more than 8 or so, the last tabs will show some generic thumbnail image instead of the tab content thumbnail/preview.

Steps:
1. Run today's nightly, Namoroka (10/15), and open several tabs, about 10 of them
2. Hover over the Namoroka icon in the task bar

Expected: All tabs should show a preview with its tab content thumbnail

Actual: Some of the tabs show a generic thumbnail icon.

This also happens in IE, however, and I can't see a pattern of when this happens except that it happens when several tabs are opened, more than 10 or close to the maximum it can display as previews.
This may have something to do with memory, because when I close some tabs, the generic thumbnail previews start showing correctly.

So, I opened several more applications in my machine, and now when I hover, more thumbnails appear blank.

Depending on the user's hardware and number of applications running, we might have very few useful tab previews to show.
In this system, the closing of other apps increases the number of tab previews shown properly. It's an older machine.
In this system, running many apps doesn't seem to make as much difference in the number of tab previews displayed, but it was easier to incur in bug 522262.
Blocks: 474056
Attached image Aero Peek bug screen
Aero Peek bug screen

Build identifier: 
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a4pre) Gecko/20100317
Minefield/3.7a4pre

Tabs:
http://www.lenta.ru/news/2010/03/19/millennium/
http://www.warandpeace.ru/
http://www.warandpeace.ru/ru/news/view/45380/
http://www.warandpeace.ru/ru/news/view/45385/
http://www.warandpeace.ru/ru/news/view/45378/
http://www.warandpeace.ru/ru/news/view/45369/
http://www.warandpeace.ru/ru/news/view/45371/
http://www.warandpeace.ru/ru/news/view/45367/
http://www.warandpeace.ru/ru/news/view/45366/
http://www.warandpeace.ru/ru/news/view/45365/
http://www.warandpeace.ru/ru/news/view/45364/

Troubleshooting Information:

Modified Preferences:
accessibility.browsewithcaret = true
browser.places.importBookmarksHTML = false
browser.places.smartBookmarksVersion = 2
browser.startup.homepage = http://www.google.ru/firefox
browser.startup.homepage_override.mstone = rv:1.9.3a4pre
browser.tabs.warnOnOpen = false
extensions.lastAppVersion = 3.7a4pre
font.language.group = x-cyrillic
network.cookie.cookieBehavior = 1
network.cookie.prefsMigrated = true
places.history.expiration.transient_current_max_pages = 16098
privacy.cpd.siteSettings = true
privacy.sanitize.migrateFx3Prefs = true
privacy.sanitize.timeSpan = 0

Extensions:
none

Plugins:
Mozilla Default Plug-in (File: npnul32.dll Version: 1.0.0.15)

OS:
Windows [Version 6.1.7600] (Ultimate) run on VMWare Player 3.01

Screen Resolution:
1440x900 px
Looking at the documentation [1], it seems that if the DWM's thumbnail cache is too big, it doesn't ask for more thumbnails. If you can reproduce this bug (and I cannot), you can use Spy++ to monitor the firefox process and see if it is sent the WM_DWMSENDICONICTHUMBNAIL message (message number 0x323). If you do see the message, then it's a bug in the documentation or our code. If you don't see the message, then Windows appears to be following the spec.

[1] http://msdn.microsoft.com/en-us/library/dd938875%28VS.85%29.aspx
I think this is by design on Microsoft's part and there's nothing we can do about it. I'm not sure we can even reliably detect this condition at runtime.
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.