Last Comment Bug 522682 - backport Breakpad issue 323 - OS X exception handler / minidump generator should set exception address correctly for EXC_BAD_ACCESS to branches
: backport Breakpad issue 323 - OS X exception handler / minidump generator sho...
Status: RESOLVED FIXED
:
Product: Toolkit
Classification: Components
Component: Breakpad Integration (show other bugs)
: Trunk
: x86 Mac OS X
: -- normal (vote)
: ---
Assigned To: Ted Mielczarek [:ted.mielczarek]
:
Mentors:
http://code.google.com/p/google-break...
Depends on:
Blocks: 416754 443738 494671
  Show dependency treegraph
 
Reported: 2009-10-16 04:37 PDT by Ted Mielczarek [:ted.mielczarek]
Modified: 2009-12-22 08:31 PST (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
beta2-fixed
.8-fixed


Attachments
branch patch (10.54 KB, patch)
2009-10-16 04:55 PDT, Ted Mielczarek [:ted.mielczarek]
sayrer: approval1.9.2+
dveditz: approval1.9.1.8+
Details | Diff | Review

Description Ted Mielczarek [:ted.mielczarek] 2009-10-16 04:37:01 PDT
You can see the patch here:
http://code.google.com/p/google-breakpad/source/detail?r=350#

We picked this up on trunk as part of a Breakpad sync in bug 510920, but that feels like way too much to take on a branch. However, this patch is pretty small and localized, and I'd feel safe taking it on a branch. It makes crash reports a lot more useful in these circumstances.

I'll put together a 1.9.2 patch for it.
Comment 1 Ted Mielczarek [:ted.mielczarek] 2009-10-16 04:55:25 PDT
Created attachment 406666 [details] [diff] [review]
branch patch

The patch applied cleanly to branch, except for changes to some files that aren't present on branch that we don't actually use in Mozilla anyway (Breakpad added a mac framework that we're not using, and I had to patch some things there).

This is a diff against 1.9.2. I'm not sure on procedure here, since this same change already landed on trunk, and has review upstream from a Breakpad peer. Do I need review again? Just approval?
Comment 2 Ted Mielczarek [:ted.mielczarek] 2009-10-16 06:53:13 PDT
Comment on attachment 406666 [details] [diff] [review]
branch patch

Well, better to set the flag than not. See the previous comment for an explanation.
Comment 3 Ted Mielczarek [:ted.mielczarek] 2009-10-16 11:06:37 PDT
Pushed to 1.9.2:
http://hg.mozilla.org/releases/mozilla-1.9.2/rev/28adff5e9307

I think we could take this on 1.9.1 as well, if it applies cleanly then it's probably fine.
Comment 4 Ted Mielczarek [:ted.mielczarek] 2009-11-10 12:39:52 PST
Comment on attachment 406666 [details] [diff] [review]
branch patch

We should take this on 1.9.1. It gives us useful extra data in crash reports. It's a pretty small patch and has been on trunk and 1.9.2 without any known problems for a while.
Comment 5 Samuel Sidler (old account; do not CC) 2009-11-10 17:27:10 PST
Comment on attachment 406666 [details] [diff] [review]
branch patch

Really too late for 1.9.1.6 if it's not a blocker. We'll have to pick this up in 1.9.1.7.
Comment 6 Ted Mielczarek [:ted.mielczarek] 2009-11-11 04:10:29 PST
That's fine, just forgot to request approval and wanted it on the radar.
Comment 7 Daniel Veditz [:dveditz] 2009-12-18 11:54:49 PST
Comment on attachment 406666 [details] [diff] [review]
branch patch

Approved for 1.9.1.8, a=dveditz for release-drivers
Comment 8 Ted Mielczarek [:ted.mielczarek] 2009-12-22 03:58:01 PST
Pushed to 1.9.1:
http://hg.mozilla.org/releases/mozilla-1.9.1/rev/54fc8007354d

You can verify this fix by installing "Crash Me Now Advanced", then using Tools -> Crash Me! -> Null pointer deref!, submitting the report, then visiting your crash report and ensuring that the "Crash Address" field is "0x0". Note that this bug is for OS X only.

http://ted.mielczarek.org/code/mozilla/crashme-advanced.xpi

Note You need to log in before you can comment on or make changes to this bug.