Export settings (feature request)

RESOLVED DUPLICATE of bug 22689

Status

()

enhancement
RESOLVED DUPLICATE of bug 22689
10 years ago
10 years ago

People

(Reporter: pisoir, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3 (.NET CLR 3.5.30729)

It would be really nice if firefox could easily save and export all its settings (bookmarks, history, etc) to one file, which could be migrated to a different computer (same way like "import" in menu "File", there could also be an "export/backup" option). 
I know there is a possibility to do it (http://support.mozilla.com/en-US/kb/Backing+up+your+information), but this options is just far from being user-friendly. 
Moreoever, it would be nice if you could select the output format, so you could export your settings to different browsers (safari, chrome, ie...).

I believe it shouldn't be that hard to add this feature, since there is already a way ho to do it manually. It only needs some automation.


Reproducible: Always
With a batch file? Need to write it only once :)
Making copies of the whole profile folder is the most preferable because it copies everything so no info will get lost. 
Or with the bookmark backup extension you can also make automated copies of all files you want.
Whiteboard: [DUPEME?]
Reporter

Comment 2

10 years ago
Just to add one thing. I forgot to mention really wonderful application
mozbackup (http://mozbackup.jasnapaka.com/) that can do the job (except the
export to different browsers format). However, I think that this application
should be part of the firefox (and thunderbird as well) by default.

Comment 3

10 years ago
FEBE can do all this for you:
https://addons.mozilla.org/en-US/firefox/addon/2109
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Whiteboard: [DUPEME?]
Duplicate of bug: 22689
You need to log in before you can comment on or make changes to this bug.