cannot find server on initial attempt at page load

RESOLVED DUPLICATE of bug 475603

Status

()

defect
--
major
RESOLVED DUPLICATE of bug 475603
10 years ago
10 years ago

People

(Reporter: cacheram, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3

Using bookmarks, typing address into address bar, or clicking a link sporadically causes 'cannot find server' message. Clicking the 'try again' button always succeeds in loading the page. IE and Opera do not have this trouble.
Started using ISP's DNS servers, tried several others (including OpenDNS's servers) and the problem persisted.


Reproducible: Always

Steps to Reproduce:
1.Launch Firefox
2.Attempt to navigate to a website, using any method
3.read the message that Firefox can't find the server
4. Click "Try Again' button to view the website
Actual Results:  
Application fails to navigate to the web page on first try

Expected Results:  
Application should navigate to web page on first try

I visited irc://irc.mozilla.org/firefox and worked with dr|z3d. The issue was resolved, both on my computer, and when I passed the fix on, it repaired a computer 1000 miles away from me. Steps required to workaround the bug:
1. In address bar type about:config
2. in filter bar, type network.dns.disablePrefetch
3. If the entry exists, set to FALSE
4. If entry does not exist, right-click in entry window and select New > Boolean
5. in the Preference Name windoe that appears, enter network.dns.disablePrefetch
6. Set the value to FALSE
7. Close Firefox, and re-launch

I am calling this a 'major' bug, because browsing is this application's main reason for existing.
Your router contains a buggy DNS forwarder or you have an LSP installed that causes this if it works again after disabling DNS prefetching.
Status: UNCONFIRMED → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 475603
You need to log in before you can comment on or make changes to this bug.