If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Time to reconsider vertical toolbars

RESOLVED DUPLICATE of bug 218280

Status

()

Firefox
Toolbars and Customization
--
enhancement
RESOLVED DUPLICATE of bug 218280
8 years ago
8 years ago

People

(Reporter: Ed Hume, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3 (.NET CLR 3.5.30729)

Firefox does not provide an option for vertical toolbars. This was not much of a problem in the past; but with the growing dominance of laptops, and with the predominance of wide aspect displays, the time for vertical toolbars has arrived. 

The upcoming Firefox versions will be working to reduce the vertical space the browser uses. This is the right thing to do, but will require an additional toolbar for quick access to various tools like text resizing, etc. The best place for a supplementary toolbar will be on a left or right margin, leaving the top space unmolested.

Firefox already provides sidebars. The extensions All-in-One Sidebars and TotalToolbar (from Mozdev) show that vertical toolbars are practical, especially the latter.

I can't find the old bug right now. I think this was wontfixed long ago. But times change. With the 3.7 UI especially, vertical toolbars need to be part of Firefox's armamentarium.

Reproducible: Always

Updated

8 years ago
OS: Windows Vista → All
Hardware: x86 → All
Version: unspecified → Trunk

Updated

8 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 218280
You need to log in before you can comment on or make changes to this bug.