MPL Initial Developer compliance for Camino 2.0 release

RESOLVED FIXED

Status

Camino Graveyard
General
RESOLVED FIXED
8 years ago
8 years ago

People

(Reporter: Smokey Ardisson (offline for a while; not following bugs - do not email), Assigned: Smokey Ardisson (offline for a while; not following bugs - do not email))

Tracking

({fixed1.9.0.16})

Details

Attachments

(1 attachment, 1 obsolete attachment)

Created attachment 406970 [details] [diff] [review]
Adds missing Camino MPL Initial Developers to about:license

In the process of checking on all the licence-related fun in advance of the Camino 2.0 release, I noticed about:license on 1.9.0.x is missing several Camino initial developers.

I've run relic against mozilla/camino on cvs trunk, run make-list-id against that, and then, noticing there were missing names, ran relic again in verbose mode and manually checked every file that verbose said had a license block but which listed an initial developer of "None"[1], adding the initial developers of those files to the original output of make-list-id.

Finally, I combined that list with the list in about:license, sorted and uniqed, and presented the results as the attached patch.

(Strictly speaking, Dan Weber's code is not shipping in Camino 2.0 since the code is not on the CAMINO_2_0_BRANCH, but license.html belongs to CVS HEAD, not the CAMINO_2_0_BRANCH, and, having spent the better part of a couple of years trying to get rid of multiple copies of license.html, I don't care to add a fork of license.html for this, so this patch is correct for CVS HEAD and a superset of the additions that would otherwise be made if license.html were branched.)

[1] These were almost all files that use the suggested boilerplate format (http://www.mozilla.org/MPL/) where the Initial Developer appears on the line following the "The Initial Developer of the Original Code is" text (with or without leading space or trailing period on this developer-name line).  I unhappily suspect relic is incapable of properly processing files that use the boilerplate format we suggest that developers use.
Attachment #406970 - Flags: review?(gerv)
Created attachment 407790 [details] [diff] [review]
v2, adds Ian Leue

This is the same as the previous patch but with the addition of Ian Leue (now that bug 523858 is fixed).

Gerv, we're freezing for Camino 2 on Monday at 5 PM US Eastern Daylight Time; I'll likely have to take this on the release minibranch due to Gecko approval mechanics, but it would be helpful if the patch I'm taking on the minibranch has actually been reviewed. ;)  Thanks!
Attachment #406970 - Attachment is obsolete: true
Attachment #407790 - Flags: review?(gerv)
Attachment #406970 - Flags: review?(gerv)
It would seriously surprise me if relic was unable to process such files. Can you give me an example of a file in your category [1]? For example:
relic -I -f camino/src/application/GrowlController.h
gives back the correct answer:
Ben Willmore

The reason Camino developers are not in the list is probably because I failed to check out the camino directory when I made the list.

There is no problem with Dan Weber's name appearing. The text at the top of this part of about:licence has some disclaimers in it which cover this sort of situation.

Gerv
Attachment #407790 - Flags: review?(gerv) → review+
(In reply to comment #2)
> It would seriously surprise me if relic was unable to process such files. Can
> you give me an example of a file in your category [1]?

The list is on another computer; I'll post it later today.  BTW, is there a place to report relic/make-list-id bugs, besides random licensing bug reports?  

Anyway, thanks again, and I'll post that list later today!
Comment on attachment 407790 [details] [diff] [review]
v2, adds Ian Leue

Requesting approval for 1.9.0.16; this is a required license.html change adding missing Camino developers to ensure MPL compliance for Camino 2.
Attachment #407790 - Flags: approval1.9.0.16?
Comment on attachment 407790 [details] [diff] [review]
v2, adds Ian Leue

Approved for 1.9.0.16, a=dveditz for release-drivers
Attachment #407790 - Flags: approval1.9.0.16? → approval1.9.0.16+
Checking in toolkit/content/license.html;
/cvsroot/mozilla/toolkit/content/license.html,v  <--  license.html
new revision: 1.29; previous revision: 1.28
done
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Keywords: fixed1.9.0.16
Resolution: --- → FIXED
Gerv: I didn't cross-check to find all the files that use the current recommended boilerplate format, so you're right that they're generally being processed correctly.  It just happened that every file that came up with a license but no initial developer had that boilerplate format, and I jumped a little too quickly :-)

Here's the list of files where relic finds the license block but comes up with an Initial Developer of 'None':

camino/src/browser/WebSearchField.mm
camino/src/browser/WebSearchField.h
camino/src/browser/ThumbnailView.m
camino/src/browser/ThumbnailView.h
camino/src/browser/TabThumbnailGridView.mm
camino/src/browser/TabThumbnailGridView.h
camino/src/browser/ContentDispatchChooser.mm
camino/src/browser/ContentDispatchChooser.h
camino/src/download/FileChangeWatcher.m
camino/src/download/FileChangeWatcher.h
camino/src/embedding/CHStringBundleOverride.mm
camino/src/embedding/CHStringBundleOverride.h
camino/src/embedding/CHPermissionManager.mm
camino/src/embedding/CHPermissionManager.h
camino/src/embedding/CHCookieStorage.mm
camino/src/embedding/CHCookieStorage.h
camino/src/embedding/CHCertificateOverrideManager.mm
camino/src/embedding/CHCertificateOverrideManager.h
camino/src/extensions/NSString+Gecko.h
I've worked out what the problem is. These files don't match the given boilerplate, in that the spaces before the intermediate "*" characters are all removed. The regex isn't forgiving in this respect. :-/

I've updated the script to cope with this difference. The result is that, running over a 1.9.0 tree which includes Camino, the only additional name in the list was Jeff Dlouhy.

Gerv
(In reply to comment #8)
> I've worked out what the problem is. These files don't match the given
> boilerplate, in that the spaces before the intermediate "*" characters are all
> removed. The regex isn't forgiving in this respect. :-/

Oh, I see that now. Odd.

(In reply to comment #8)
> I've updated the script to cope with this difference. The result is that,
> running over a 1.9.0 tree which includes Camino, the only additional name in
> the list was Jeff Dlouhy.

I'm confused by this part. What sort of 1.9.0?  Jeff's in the list as of 1.9.0.16 (because of this patch), and anything before this patch landed should have had the others in this patch missing.

Is there a place in Bugzilla to file bugs and attach patches on this code? I made some local changes to add support for more file types and to ignore a lot of non-applicable files for less noise, and it'd be useful in the long-run to get them off of my disk ;)
No, this code does not have its own Bugzilla component. Looking, the only half-sane place is Webtools, but it's not a webtool. Let me look into it.

Gerv
To answer your other question: I took a 1.9.0 tree I had, and told it to check out camino as well. I then ran relic over the total result. The only additional name in the final cooked list was Jeff's. 

If you can point me at the code files that relic apparently missed in order to not include the other four people (none of their names apart from Jeff's appear as the Initial Developer in the files specifically listed in comment #7) then I'll see why they didn't appear too. Perhaps there's a different bug causing relic to miss them.

Gerv
(In reply to comment #11)
> If you can point me at the code files that relic apparently missed in order to
> not include the other four people (none of their names apart from Jeff's appear
> as the Initial Developer in the files specifically listed in comment #7) then
> I'll see why they didn't appear too. Perhaps there's a different bug causing
> relic to miss them.

Ben Willmore: camino/src/application/GrowlController.{h|mm}

Daniel Weber: camino/src/extensions/AutoCompleteResult.{h|m}
              camino/src/extensions/AutoCompleteCell.{h|m}

Ian Leue: camino/src/extensions/NSTextView+Utils.{h|m}

Philippe Wittenbergh: camino/resources/application/aquaSelect.css

Smokey Ardisson: camino/feedhandlers/feedhandlers.applescript.in*
                 camino/tools/os-symbol-generation/generate_macosx_symbols

* This file required a patch to relic in order to be detected properly; I added
     ".applescript": (["(*", " *", "*)"], ["--"]),
in _g_basename_to_comment_info.
> in _g_basename_to_comment_info.

I assume you mean _g_ext_to_comment_info?

Those files now all work.

Gerv
You can now file bugs on relic in product:mozilla.org, component:Relic.
https://bugzilla.mozilla.org/enter_bug.cgi?product=mozilla.org&component=Relic

Gerv
You need to log in before you can comment on or make changes to this bug.