Last Comment Bug 523089 - [*|attr] selector doesn't round-trip correctly
: [*|attr] selector doesn't round-trip correctly
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: CSS Parsing and Computation (show other bugs)
: Trunk
: x86 Mac OS X
: -- normal with 1 vote (vote)
: ---
Assigned To: Boris Zbarsky [:bz] (still a bit busy)
:
: Jet Villegas (:jet)
Mentors:
http
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-10-19 06:02 PDT by Boris Zbarsky [:bz] (still a bit busy)
Modified: 2009-10-20 10:28 PDT (History)
1 user (show)
bzbarsky: in‑testsuite+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Fix (3.81 KB, patch)
2009-10-19 22:33 PDT, Boris Zbarsky [:bz] (still a bit busy)
dbaron: review+
Details | Diff | Splinter Review

Description Boris Zbarsky [:bz] (still a bit busy) 2009-10-19 06:02:50 PDT
In particular, it becomes [attr], which is the same thing as [|attr], since the default namespace doesn't apply to attribute selectors.
Comment 1 Boris Zbarsky [:bz] (still a bit busy) 2009-10-19 22:33:09 PDT
Created attachment 407227 [details] [diff] [review]
Fix
Comment 2 David Baron :dbaron: ⌚️UTC-8 2009-10-20 08:41:20 PDT
Comment on attachment 407227 [details] [diff] [review]
Fix

>+          NS_ASSERTION(prefixAtom,
>+                       "How did we end up with a namespace if the prefix "
>+                       "is unknown?");

Maybe worth commenting that a non-none namespace on attributes can't have come from the default, since the default doesn't apply?

>diff --git a/layout/style/test/test_namespace_rule.html b/layout/style/test/test_namespace_rule.html

Did you test that some of the serialize-and-rematch tests failed without the patch?  (Did any others fail without it?)

r=dbaron
Comment 3 Boris Zbarsky [:bz] (still a bit busy) 2009-10-20 08:46:08 PDT
> Did you test that some of the serialize-and-rematch tests failed without the
> patch? 

Yes, precisely.  The two [*|foo] tests failed serialize-and-rematch.

> (Did any others fail without it?)

No.

Will add the comment.
Comment 4 Boris Zbarsky [:bz] (still a bit busy) 2009-10-20 10:28:44 PDT
Pushed http://hg.mozilla.org/mozilla-central/rev/6af13824b513 with the comment added.

Note You need to log in before you can comment on or make changes to this bug.