Mid-air collision when marking as duplicate not handled correctly

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
9 years ago
9 years ago

People

(Reporter: knocte, Unassigned)

Tracking

Details

(Reporter)

Description

9 years ago
This just happened to me with the bugzilla instance installed on http://bugzilla.gnome.org/, so I'm not sure if this bug is fixed upstream already.

The steps to reproduce that I think would apply more generally to my case would be:
1. Create bug number 2 by user X.
2. User Y opens the bug no. 2 in his browser, and waits.
3. User Z opens the bug no. 2 in his browser and marks it as DUPLICATE of bug no. 1.
4. User Y marks bug no. 2 as DUPLICATE of bug 1 and clicks on COMMIT button.

Current results:
User Y receives this stack trace:

Software error:

DBD::mysql::db do failed: Duplicate entry '504492-12875' for key 1 [for Statement "INSERT INTO cc (bug_id, who) VALUES (?,?)"] at /var/www/bugzilla.gnome.org/Bugzilla/Bug.pm line 683
	Bugzilla::Bug::update('Bugzilla::Bug=HASH(0x2b2a163a12b0)') called at /var/www/bugzilla.gnome.org/Bugzilla/Bug.pm line 854
	Bugzilla::Bug::update('Bugzilla::Bug=HASH(0x2b2a163765b0)', '2009-10-19 16:33:02') called at /var/www/bugzilla.gnome.org/process_bug.cgi line 547
	ModPerl::ROOT::Bugzilla::ModPerl::ResponseHandler::var_www_bugzilla_2egnome_2eorg_process_bug_2ecgi::handler('Apache2::RequestRec=SCALAR(0x2b2a13ca6640)') called at /usr/lib64/perl5/vendor_perl/5.8.8/x86_64-linux-thread-multi/ModPerl/RegistryCooker.pm line 204
	eval {...} called at /usr/lib64/perl5/vendor_perl/5.8.8/x86_64-linux-thread-multi/ModPerl/RegistryCooker.pm line 204
	ModPerl::RegistryCooker::run('Bugzilla::ModPerl::ResponseHandler=HASH(0x2b2a160f2880)') called at /usr/lib64/perl5/vendor_perl/5.8.8/x86_64-linux-thread-multi/ModPerl/RegistryCooker.pm line 170
	ModPerl::RegistryCooker::default_handler('Bugzilla::ModPerl::ResponseHandler=HASH(0x2b2a160f2880)') called at /usr/lib64/perl5/vendor_perl/5.8.8/x86_64-linux-thread-multi/ModPerl/Registry.pm line 31
	ModPerl::Registry::handler('Bugzilla::ModPerl::ResponseHandler', 'Apache2::RequestRec=SCALAR(0x2b2a13ca6640)') called at /var/www/bugzilla.gnome.org/mod_perl.pl line 104
	Bugzilla::ModPerl::ResponseHandler::handler('Bugzilla::ModPerl::ResponseHandler', 'Apache2::RequestRec=SCALAR(0x2b2a13ca6640)') called at -e line 0
	eval {...} called at -e line 0

For help, please send mail to the webmaster (bugmaster@gnome.org), giving this error message and the time and date of the error.

Comment 1

9 years ago
Hum, I cannot reproduce using Bugzilla 3.4.2 and 3.5. I get the midair collision page telling me that someone already marked the bug as duplicate, and if I click "submit my changes anyway", nothing happens as the bug has already been marked as a duplicate. Is your problem reproducible? And can you reproduce on e.g. our test installation https://landfill.bugzilla.org/bugzilla-3.4-branch/ ?

Cc'ing bkor in case he knows something about this problem. WFM for now.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 2

9 years ago
Thanks for your comment.

(In reply to comment #1)
> Hum, I cannot reproduce using Bugzilla 3.4.2 and 3.5. I get the midair
> collision page telling me that someone already marked the bug as duplicate, 

Mmmm, then I wonder if maybe steps 3 and 4 were so closed together that they resulted in some transaction issue? I mean, step 4 starting before step 3 finishes. I'll check if I have time to test with the test installation.
You need to log in before you can comment on or make changes to this bug.