Last Comment Bug 523162 - prtypes.h always included in a CROSS_COMPILE build
: prtypes.h always included in a CROSS_COMPILE build
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: unspecified
: x86 Mac OS X
: -- normal (vote)
: ---
Assigned To: general
:
:
Mentors:
Depends on: 694499
Blocks:
  Show dependency treegraph
 
Reported: 2009-10-19 11:27 PDT by ash_mozilla
Modified: 2012-06-20 07:38 PDT (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Simple patch. (367 bytes, patch)
2009-10-19 11:29 PDT, ash_mozilla
no flags Details | Diff | Splinter Review

Description ash_mozilla 2009-10-19 11:27:28 PDT
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_5_8; en-us) AppleWebKit/532.3+ (KHTML, like Gecko) Version/4.0.3 Safari/531.9
Build Identifier: 

jscpucfg.cpp always includes prtypes.h in a cross compile build.

Patch coming

Reproducible: Always
Comment 1 ash_mozilla 2009-10-19 11:29:15 PDT
Created attachment 407068 [details] [diff] [review]
Simple patch.
Comment 2 Jason Orendorff [:jorendorff] 2009-10-22 15:59:58 PDT
I don't think we want this exact patch because prtypes.h is what defines IS_BIG_ENDIAN.
Comment 3 ash_mozilla 2009-10-22 16:16:27 PDT
Ahh, this makes a bit more sense. So some form of autoconf test to see if nspr exists for the cross-compile target might be the way to go?
Comment 4 Vladimir Vukicevic [:vlad] [:vladv] 2009-11-20 14:47:27 PST
(In reply to comment #3)
> Ahh, this makes a bit more sense. So some form of autoconf test to see if nspr
> exists for the cross-compile target might be the way to go?

No, the problem is that even if you're building with NSPR, jscpucfg is built with the -host- compiler, since it's going to generate a .h file.  So the nspr prtypes.h isn't useful.
Comment 5 Ted Mielczarek [:ted.mielczarek] 2012-06-20 07:38:32 PDT
bug 694499 removed jscpucfg.

Note You need to log in before you can comment on or make changes to this bug.