Closed Bug 523479 Opened 10 years ago Closed 10 years ago

minify all *.js from extensions

Categories

(Firefox :: General, defect, P2)

defect

Tracking

()

RESOLVED WONTFIX

People

(Reporter: the_invincible, Unassigned)

Details

(Keywords: perf, Whiteboard: [ts])

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3 GTB6 (.NET CLR 3.5.30729) FirePHP/0.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3 GTB6 (.NET CLR 3.5.30729) FirePHP/0.3

Hello, 

i've looked in my AVAST Antivirus Programm an i see, that firefox realy reads hunderts of thousends of small files... that really bad for hardisk performance. 
I think on the low speed harddrives in notebooks... and not good against fragement building on harddisk...

why firefox doesn't store the content of the Plugin in DB like SQLlite? (for places for exampled quite fast (with my 1.400 bookmarks :-))

firefox has really many extensions i use and this slows down the starup performance extremly! (because of loading so many files, before the window is shown) 

the layout of firefox should be cached (Traybar and so on) then you could show the main window really fast, because the functions could be load later, i think firefox use late binding? 

only some minds about performance... - never forget performance is the key! :-)

Reproducible: Always

Steps to Reproduce:
1.Install 40 Extensions 
2.Restart your browser 
3.wait...wait...
confirmed for extensions code. i'll file another bug for core js code minification. see bug 513132 for css compression for core files.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: perf
OS: Windows XP → All
Hardware: x86 → All
Whiteboard: [ts]
Summary: Startup speedup by compact all *.js from the plugins like minify do → minify all *.js from extensions
Priority: -- → P2
the cost to debugging is too high, given the small set of circumstances in which this would actually help. better to focus on JAR compression, see bug 524858 for further discussion. -> WONTFIX.
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → WONTFIX
I know this has been marked as WONTFIX, however, I wanted to share this article that I found showing that the code minified with YUI Compressor parses faster.

http://carlos.bueno.org/2010/02/measuring-javascript-parse-and-load.html?v=2

I believe the focus is web based applications, but Firefox uses quite a bit of Javascript behind the scenes too, right?
You need to log in before you can comment on or make changes to this bug.