test_places/queries/test_redirectsMode.js fails, and then reports a failure in head_queries.js

RESOLVED FIXED

Status

()

defect
RESOLVED FIXED
10 years ago
7 years ago

People

(Reporter: dbaron, Unassigned)

Tracking

({intermittent-failure})

Trunk
x86
macOS
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1256131500.1256133470.2230.gz
OS X 10.5.2 mozilla-central test opt everythingelse on 2009/10/21 06:25:00  

TEST-UNEXPECTED-FAIL | /builds/slave/mozilla-central-macosx-opt-unittest-everythingelse/build/xpcshell/tests/test_places/queries/test_redirectsMode.js | test failed (with xpcshell return code: 0), see following log:

...

TEST-UNEXPECTED-FAIL | /builds/slave/mozilla-central-macosx-opt-unittest-everythingelse/build/xpcshell/tests/test_places/queries/head_queries.js | 1256133025493997 == 0 - See following stack:
JS frame :: /builds/slave/mozilla-central-macosx-opt-unittest-everythingelse/build/xpcshell/head.js :: do_throw :: line 197
JS frame :: /builds/slave/mozilla-central-macosx-opt-unittest-everythingelse/build/xpcshell/head.js :: do_check_eq :: line 227
JS frame :: /builds/slave/mozilla-central-macosx-opt-unittest-everythingelse/build/xpcshell/tests/test_places/queries/head_queries.js :: compareArrayToResult :: line 409
JS frame :: /builds/slave/mozilla-central-macosx-opt-unittest-everythingelse/build/xpcshell/tests/test_places/queries/test_redirectsMode.js :: check_results_callback :: line 123
JS frame :: /builds/slave/mozilla-central-macosx-opt-unittest-everythingelse/build/xpcshell/tests/test_places/queries/test_redirectsMode.js :: cartProd :: line 177
JS frame :: /builds/slave/mozilla-central-macosx-opt-unittest-everythingelse/bui
ld/xpcshell/tests/test_places/queries/test_redirectsMode.js :: run_test :: line 
299
JS frame :: /builds/slave/mozilla-central-macosx-opt-unittest-everythingelse/bui
ld/xpcshell/head.js :: _execute_test :: line 125
JS frame :: -e :: <TOP_LEVEL> :: line 1
TEST-INFO | (xpcshell/head.js) | exiting test
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: acid3
wrong bug...
Duplicate of bug: 510460
Not a duplicate, that was apparently about fixing some (invisible to me) XXX commented out tests.

OS X 10.5.2 mozilla-central test opt everythingelse on 2009/10/22 11:11:40  
http://tinderbox.mozilla.org/showlog.cgi?tree=Firefox-Unittest&errorparser=unittest&logfile=1256235100.1256237052.29549.gz&buildtime=1256235100&buildname=OS%20X%2010.5.2%20mozilla-central%20test%20opt%20everythingelse&fulltext=1#err2

OS X 10.5.2 mozilla-central test everythingelse [testfailed] Started 11:57,
finished 12:34
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1256237857.1256239988.30269.gz&fulltext=1

OS X 10.5.2 mozilla-central test opt everythingelse [testfailed] Started 14:54,
finished 15:31
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1256248480.1256250602.17951.gz&fulltext=1

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1256372298.1256374159.4102.gz

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1256539620.1256542181.29305.gz
OS X 10.5.2 mozilla-central test everythingelse on 2009/10/25 23:47:00
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Status: REOPENED → NEW
Whiteboard: [orange]
Version: 3.5 Branch → Trunk
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1256597412.1256599458.11957.gz
OS X 10.5.2 mozilla-central test opt everythingelse on 2009/10/26 15:50:12
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1256890451.1256892284.1606.gz
OS X 10.5.2 mozilla-central test opt everythingelse on 2009/10/30 01:14:11
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1256936502.1256939329.28791.gz
OS X 10.5.2 mozilla-central test everythingelse on 2009/10/30 14:01:42
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1256999707.1257001536.11311.gz
OS X 10.5.2 mozilla-central test opt everythingelse on 2009/10/31 07:35:07
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1257114455.1257116615.4926.gz#err2
OS X 10.5.2 mozilla-central test everythingelse on 2009/11/01 14:27:35
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1257119970.1257122225.1058.gz#err2
OS X 10.5.2 mozilla-central test everythingelse on 2009/11/01 15:59:30
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1257126984.1257129054.10946.gz#err2
OS X 10.5.2 mozilla-central test opt everythingelse on 2009/11/01 17:56:24
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1257137387.1257139692.28785.gz#err294
OS X 10.5.2 mozilla-central test everythingelse on 2009/11/01 20:49:47
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1257179209.1257181346.15366.gz
OS X 10.5.2 mozilla-central test everythingelse on 2009/11/02 08:26:49
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1257156660.1257158591.7655.gz
OS X 10.5.2 mozilla-central test opt everythingelse on 2009/11/02 02:11:00
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1257281227.1257283792.13458.gz
OS X 10.5.2 mozilla-central test everythingelse on 2009/11/03 12:47:07
Summary: random failure of test_places/queries/test_redirectsMode.js → test_places/queries/test_redirectsMode.js fails, and then reports a failure in head_queries.js
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1257291581.1257294012.32411.gz
OS X 10.5.2 mozilla-central test opt everythingelse on 2009/11/03 15:39:41
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1257312856.1257314781.2858.gz
OS X 10.5.2 mozilla-central test opt everythingelse on 2009/11/03 21:34:16
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1257534392.1257536241.10482.gz
OS X 10.5.2 mozilla-central opt test everythingelse on 2009/11/06 11:06:32
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1257564578.1257566429.17833.gz
OS X 10.5.2 mozilla-central opt test everythingelse on 2009/11/06 19:29:38

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1257567200.1257569192.3143.gz
OS X 10.5.2 mozilla-central opt test everythingelse on 2009/11/06 20:13:20
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1257695364.1257697556.12622.gz
OS X 10.5.2 mozilla-central test everythingelse on 2009/11/08 07:49:24
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1257703406.1257707189.26368.gz
Linux mozilla-central debug test everythingelse on 2009/11/08 10:03:26
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1258021734.1258023643.10223.gz
OS X 10.5.2 mozilla-central opt test everythingelse on 2009/11/12 02:28:54
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1258141406.1258144539.6624.gz
OS X 10.5.2 mozilla-central test everythingelse on 2009/11/13 11:43:26
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1258210925.1258213261.32537.gz
OS X 10.5.2 mozilla-central opt test everythingelse on 2009/11/14 07:02:05
s: moz2-darwin9-slave17
Blocks: 438871
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1258528732.1258531627.5927.gz
OS X 10.5.2 mozilla-central test everythingelse on 2009/11/17 23:18:52
s: moz2-darwin9-slave13
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1258638825.1258641957.13443.gz
OS X 10.5.2 mozilla-central test everythingelse on 2009/11/19 05:53:45
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1258654732.1258660017.29274.gz
OS X 10.5.2 mozilla-central test everythingelse on 2009/11/19 10:18:52
s: moz2-darwin9-slave13
TEST-UNEXPECTED-FAIL | /builds/slave/mozilla-central-macosx-unittest-everythingelse/build/xpcshell/tests/test_places/queries/test_redirectsMode.js | test failed (with xpcshell return code: 0), see following log:
TEST-UNEXPECTED-FAIL | /builds/slave/mozilla-central-macosx-unittest-everythingelse/build/xpcshell/tests/test_places/queries/head_queries.js | 1258656755970997 == 0 - See following stack:
taking for investigation, looks like frequent enough to be considered a priority.
Assignee: nobody → mak77
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1258652611.1258655782.12010.gz
OS X 10.5.2 mozilla-central opt test everythingelse on 2009/11/19 09:43:31
s: moz2-darwin9-slave14
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1258666779.1258669580.9463.gz
OS X 10.5.2 mozilla-central opt test everythingelse on 2009/11/19 13:39:39
s: moz2-darwin9-slave12
TEST-UNEXPECTED-FAIL | /builds/slave/mozilla-central-macosx-opt-unittest-everythingelse/build/xpcshell/tests/test_places/queries/test_redirectsMode.js | test failed (with xpcshell return code: 0), see following log:
TEST-UNEXPECTED-FAIL | /builds/slave/mozilla-central-macosx-opt-unittest-everythingelse/build/xpcshell/tests/test_places/queries/head_queries.js | 1258668664271997 == 0 - See following stack:
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1259068788.1259071105.10780.gz
OS X 10.5.2 mozilla-central opt test everythingelse on 2009/11/24 05:19:48
s: moz2-darwin9-slave12
TEST-UNEXPECTED-FAIL | /builds/slave/mozilla-central-macosx-opt-unittest-everythingelse/build/xpcshell/tests/test_places/queries/test_redirectsMode.js | test failed (with xpcshell return code: 0), see following log:
TEST-UNEXPECTED-FAIL | /builds/slave/mozilla-central-macosx-opt-unittest-everythingelse/build/xpcshell/tests/test_places/queries/head_queries.js | 1259070395268997 == 0 - See following stack:
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1259107109.1259111035.17460.gz
OS X 10.5.2 mozilla-central test everythingelse on 2009/11/24 15:58:29
s: moz2-darwin9-slave15
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1259173877.1259176599.23806.gz&fulltext=1

OS X 10.5.2 mozilla-central test everythingelse [testfailed] Started 13:31, finished 14:17

s: moz2-darwin9-slave15TEST-UNEXPECTED-FAIL | /builds/slave/mozilla-central-macosx-unittest-everythingelse/build/xpcshell/tests/test_places/queries/test_redirectsMode.js | test failed (with xpcshell return code: 0), see following log:
TEST-UNEXPECTED-FAIL | /builds/slave/mozilla-central-macosx-unittest-everythingelse/build/xpcshell/tests/test_places/queries/head_queries.js | 1259175557088997 == 0 - See following stack:
hopefully workarounded on trunk
Whiteboard: [orange] → [orange][workarounded by bug521225 on trunk]
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
Whiteboard: [orange][workarounded by bug521225 on trunk] → [orange]
Whiteboard: [orange] → [orange][worked around by bug521225 on trunk]
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox3.6/1267766173.1267766577.24197.gz
OS X 10.5.2 mozilla-1.9.2 test xpcshell on 2010/03/04 21:16:13
s: moz2-darwin9-slave13
Assignee: mak77 → nobody
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox3.6/1276344350.1276344759.7675.gz

TEST-UNEXPECTED-FAIL | /builds/slave/mozilla-1.9.2-macosx-unittest-xpcshell/build/xpcshell/tests/test_places/queries/test_redirectsMode.js | test failed (with xpcshell return code: 0), see following log:
TEST-UNEXPECTED-FAIL | /builds/slave/mozilla-1.9.2-macosx-unittest-xpcshell/build/xpcshell/tests/test_places/queries/head_queries.js | 1276344478981997 == 0 - See following stack:
Whiteboard: [orange][worked around by bug521225 on trunk] → [orange]
Disabled on Windows on Places branch:
http://hg.mozilla.org/projects/places/rev/776291003f32
Whiteboard: [orange] → [orange][disabled on Windows on Places branch]
should now have been fixed along with bug 619672
Status: NEW → RESOLVED
Closed: 10 years ago9 years ago
Depends on: 619672
Resolution: --- → FIXED
Whiteboard: [orange][disabled on Windows on Places branch] → [orange]
Whiteboard: [orange]
You need to log in before you can comment on or make changes to this bug.