If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Crash on Open It for jpg mail attachment.

VERIFIED WORKSFORME

Status

MailNews Core
Backend
P3
major
VERIFIED WORKSFORME
17 years ago
9 years ago

People

(Reporter: laurel, Assigned: Scott MacGregor)

Tracking

({crash})

Trunk
x86
Linux
crash

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [rtm-])

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
Using sep12 commercial build
Can't reproduce on other platforms

I'm crashing when opening a jpg mail attachment.

1.  Browser window isn't open.
2.  Logged into IMAP mail account got a message with a single jpg attachment.
3.  Message text displayed, jpg attachment displayed in message pane (some
instances the jpg did not render in message pane).
4.  Selected attachment icon, clicked on attachment name, chose Open It then OK
in open/save file dialog.

Result: crash occurred.

Note:  Tried various jpgs, all crashed.  Tried gifs, didn't crash.

Talkback incidents (not good stack info): 17313377, 17312969, 17312702.

 Call Stack:    (Signature = nsDocumentOpenInfo::OnStartRequest() 53a4fe03) 
     
 
nsDocumentOpenInfo::OnStartRequest()                                             
  nsStreamConverter::OnStartRequest()                                           
  nsDocumentOpenInfo::OnStartRequest()    
  nsOnStartRequestEvent::HandleEvent()
  nsStreamListenerEvent::HandlePLEvent()    
  PL_HandleEvent()
  PL_ProcessPendingEvents()
  nsEventQueueImpl::ProcessPendingEvents()
  event_processor_callback()
  our_gdk_io_invoke()
  libglib-1.2.so.0 + 0xe3ca (0x408803ca)
  libglib-1.2.so.0 + 0xfa86 (0x40881a86)
  libglib-1.2.so.0 + 0x10041 (0x40882041)
  libglib-1.2.so.0 + 0x101e1 (0x408821e1)
  libgtk-1.2.so.0 + 0x8b7a9 (0x407ae7a9)
  nsAppShell::Run() 
  nsAppShellService::Run()
  main1()
  main()
  libc.so.6 + 0x17cb3 (0x40252cb3)
(Reporter)

Updated

17 years ago
QA Contact: esther → pmock

Comment 1

17 years ago
Scott,

I was able to reproduce a similar situation on my RedHat 6.2.  In my case, I 
could not reliably open a jpg attachment.  I either, a) freeze the application, 
b) a browser window opens but displays the attachment url, or 3) it renders the 
image.  When I freeze, talkback does not launch to give me a chance to capture 
the crash.

I will attach a sample mail message for your viewing pleasure.

Comment 2

17 years ago
Doh... it would help to say, I was testing with the Linux commercial build 
2000-091208-m18.

Comment 3

17 years ago
Created attachment 14555 [details]
PNG and JPG attachment sent from Communicator 4.74

Comment 4

17 years ago
I have not been able to reproduce on win32 commercial build 2000-091208-m18

Comment 5

17 years ago
*spam*

adding crash keyword...
Keywords: crash
(Assignee)

Comment 6

17 years ago
putting on the rtm radar.
Keywords: rtm
(Assignee)

Comment 7

17 years ago
interesting....it seems I only crash on linux when you don't already have a
browser window open to display the message. If I have a browser window open, it
works great.

Comment 8

17 years ago
marking [rtm-] because it works with the browser window open and it happens only 
when opening a jpeg attachment.
Whiteboard: [rtm-]

Comment 9

17 years ago
I tried this on the 10/19 MN6 Linux. Had netscape set to only open the mail
window on start. Start up, select email with just a jpg, click on attachment,
select the jpg and save.
It works-for-me.
Tried emails from both ns6 and 4.75

Comment 10

17 years ago
Mozilla/5.0 (X11; U; Linux 2.2.14-5.0smp i686; en-US; m18) Gecko/20001115

I get a particular symptom: Open a News article with an attachment, try to open
the attachment with Open It, it give me a new window with the URL, but no image
(a jpeg, in this case.)

To add to the fun, I can never view a message in that newsgroup again, unless I
leave it, and come back.

And just to complete the travesty, it closed all my regular browser windows,
though that could be unrelated.

Comment 11

17 years ago
Assign it to myself.
QA Contact: pmock → fenella

Comment 12

17 years ago
To Esther ..
QA Contact: fenella → esther

Comment 13

17 years ago
It sounds like we're getting different reports of whether this is still
happening or not. Esther or Laurel, could you see if this is still happening?
(Reporter)

Comment 14

17 years ago
Using feb19 commercial trunk: I no longer see the Open It line, it just opens
automatically and I see no problems with the opening of the jpg. I'll let Esther
give it a try.

Comment 15

17 years ago
Using mac and windows builds 03-02-01 and linux build 03-02-01 basic opening of
.jpg file does not crash.   However, we have a bug that we no longer get the
options as dialog when clicking on a .jpg, so this bug as reported can't be
fully tested until we get the Option box to open it or save it.  Will check
again when that bug is fixed.

Comment 16

17 years ago
This not a problem any more used build 2001-05-03b on win, mac and linux.  
resolving as worksforme and verifying
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME

Comment 17

17 years ago
verified
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.