If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Breakpad support for Updater.exe?

RESOLVED DUPLICATE of bug 523915

Status

()

Toolkit
Crash Reporting
RESOLVED DUPLICATE of bug 523915
8 years ago
8 years ago

People

(Reporter: Barry Marshall, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.3a1pre) Gecko/20091019 Minefield/3.7a1pre (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.3a1pre) Gecko/20091019 Minefield/3.7a1pre (.NET CLR 3.5.30729) ID:20091019043323

Since I'm running Minefield all the time and don't shutdown my system, I usually have a pending Software Update hanging around.

When I occasionally run into a Minefield crash I'll get Breakpad coming up and asking for more info, which I dutifully submit in.

After I submit my crash data, I think Updater then tries to do its thing, but because my Gecko environment is unstable I then get a crash with updater.exe.   

I would at this point expect to get yet another Breakpad instance to come up and gather more data about this additional crash, but it just faults out at this point.

So is Breakpad enabled for Updater?

Reproducible: Always

Steps to Reproduce:
1.Startup Minefield
2.Wait for a Software Update to occur in the background and download all the code for application on restart
3.Crash Minefield somehow.
4.Allow Breakpad to come up and send crash data off to servers
  (my firewall app wants this confirmed all the time, so this part can be a bit slow to execute)
5.Updater.exe then attempts to update my codebase.
Actual Results:  
Pop-up with the following message:
Faulting application updater.exe, version 1.9.3.3579, faulting module updater.exe, version 1.9.3.3579, fault address 0x000080e3.



Expected Results:  
Additional Breakpad instance to catch updater.exe fault?
Updater to not attempt "update and restart" process after Breakpad starts due to crash?
I just hit and filed this today. :)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 523915
FWIW, it's not worth trying to enable breakpad in the updater, we should just fix the updater.
You need to log in before you can comment on or make changes to this bug.