Add drag and drop support for multiple objects to nsDataObj

RESOLVED DUPLICATE of bug 513464

Status

()

enhancement
RESOLVED DUPLICATE of bug 513464
10 years ago
9 years ago

People

(Reporter: khuey, Unassigned)

Tracking

Trunk
mozilla1.9.2a1
x86
Windows 7
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

The nsDataObj implementation does not support dragging and dropping multiple objects simultaneously.

Example:
1) Select (using Ctrl) two disjoint pieces of text on a web page
2) Drag that text to the search box

Result:
Both chunks of text appear in the search box

3) Drag that same text out of firefox and into another program (I used notepad++, but just about anything should work)

Result:
Only the first chunk of text appears in the external program

Goal:
Both chunks of external text appear in the external program.

Note that this isn't limited to just text, it also applies to files and similar stuff as well.

Updated

10 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 513464
Target Milestone: mozilla1.9.3a1 → mozilla1.9.2a1
You need to log in before you can comment on or make changes to this bug.