Beginning on October 25th, 2016, Persona will no longer be an option for authentication on BMO. For more details see Persona Deprecated.
Last Comment Bug 524084 - In-built DNS cache doesn't respect RR's TTLs
: In-built DNS cache doesn't respect RR's TTLs
Status: RESOLVED DUPLICATE of bug 151929
Product: Firefox
Classification: Client Software
Component: General (show other bugs)
: unspecified
: x86 Windows XP
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
Depends on:
  Show dependency treegraph
Reported: 2009-10-23 03:43 PDT by Edam
Modified: 2009-11-01 17:47 PST (History)
2 users (show)
See Also:
Crash Signature:
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Description Edam 2009-10-23 03:43:09 PDT
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv: Gecko/20090715 Firefox/3.5.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv: Gecko/20090715 Firefox/3.5.1

Firefox's bult-in DNS cache doesn't respect the TTL (time to live) of the resource records (RRs) returned by the DNS server. I read (somewhere on the net) that Firefox instead caches DNS lookups for 1 minute.

In addition to not being standards compliant, this also breaks desired DNS behaviour in circumstances where someone would want to set up a DNS server to give out different responses based on various conditions (such as time, or user authentication status, etc).

Apologies if this is an old/know issue. I searched first, but couldn't find it.

Reproducible: Always

Steps to Reproduce:
1. set up a DNS server that resolves a domain name to an initial IP address and specify a TTL of, say, 5 seconds.
2. browse to that domain name in FF
3. quickly (within, say, 30 seconds) change the DNS server to resolve that domain name to a different IP address
4. browser to that domain name again in FF.
Actual Results:  
Firefox visits the HTTP server at the initial IP address both steps 2) and 4).

Expected Results:  
Firefox should visit the HTTP server at the initial IP address in step 2) and at the different IP address in step 4).

Firefox should not cache the DNS lookup of the domain for longer than 5 seconds, as specified by the DNS server. Instead, FF keeps the DNS lookup for longer than the 5 seconds and, in step 4), fails to re-lookup the domain name.
Comment 1 Matthias Versen [:Matti] 2009-10-23 03:51:29 PDT
If you read it somewhere it's very likely that this is already reported

*** This bug has been marked as a duplicate of bug 151929 ***

Note You need to log in before you can comment on or make changes to this bug.