Closed Bug 524301 Opened 10 years ago Closed 10 years ago

Save as webpage complete ignores CSS @import files.

Categories

(Firefox :: General, defect, minor)

x86_64
Windows 7
defect
Not set
minor

Tracking

()

VERIFIED DUPLICATE of bug 126309

People

(Reporter: matt_a_nice_guy_2000, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-GB; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-GB; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3

When choosing to save a complete copy of a webpage offline, any CSS files referenced in a CSS @import are not downloaded.

The referenced URI is a page that demonstrates this.

Reproducible: Always

Steps to Reproduce:
1. Attempt to save a web page as "Web page, complete" with a site using CSS files that import other CSS files.
2. Files downloaded don't include the CSS files referenced via a CSS import.
Actual Results:  
CSS files referenced from a @import are not downloaded.

Expected Results:  
All files referenced to be downloaded.

Recursively traversed the included CSS files and saved any CSS files referenced with an @import call
Status: UNCONFIRMED → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: @importSave
v.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.