Finnish dictionary fails to load on Firefox pre3.6b1

RESOLVED FIXED

Status

defect
RESOLVED FIXED
10 years ago
9 years ago

People

(Reporter: ville.pohjanheimo, Assigned: ville.pohjanheimo)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

10 years ago
Finnish dictionary fails to load on Firefox pre3.6b1 creating an error in the javascript console

Tested on Windows 7 (64bit) and Debian/SID 64bit with 32 bit Firefox, clean profiles.

Windows 7: Loading of the spell checker fails: 
Build identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2b1pre) Gecko/20091014 Namoroka/3.6b1pre

From Javascript console:
Failed to get directories where Voikko libraries and data are installed

mozvoikko installed at C:\Users\Ville\AppData\Roaming\Mozilla\Firefox\Profiles\lr9wlpae.dsfghjkl\extensions\fi@dictionaries.addons.mozilla.org\platform\WINNT_x86-msvc\components\mozvoikko.dll

Similar problem with 32bit Firefox on 64bit Debian/SID:
Build identifier: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.2b1pre) Gecko/20091014 Namoroka/3.6b1pre

From Javascript console:
Failed to get directories where Voikko libraries and data are installed

mozvoikko installed at /home/ville/.mozilla/firefox/kuo5c30o.FF-HD/extensions/fi@dictionaries.addons.mozilla.org/platform/Linux_x86_64-gcc3/components/libmozvoikko.so

Comment 1

10 years ago
I suspect the problem is what I tried to report earlier:
https://bugzilla.mozilla.org/show_bug.cgi?id=477096

The solution is not to use nsIXULRuntime which is intentionally not compatible between 3.[05] and 3.6pre. In current SVN version of mozvoikko it is no more used and result it should work also for 3.6pre.

Comment 2

10 years ago
Verified current SVN version of mozvoikko (also libvoikko-1.2.1, suomi-malaga-1.4) under Linux (part ix86, part x86_64) with:

- firefox-3.5.3
- Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.2b2pre) Gecko/20091027 Namoroka/3.6b2pre
- Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.9.3a1pre) Gecko/20091027 Minefield/3.7a1pre
- Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.9.3a1pre) Gecko/20091027 Shredder/3.1a1pre
- Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.3a1pre) Gecko/20091027 SeaMonkey/2.1a1pre

(of course all that after updating version range).
(Assignee)

Comment 3

9 years ago
Fixed with version 1.0.1 ( https://addons.mozilla.org/fi/firefox/addons/versions/3826#version-1.0.1 )
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.