If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Spell checker corrects "etc" to "etc." infinitely

RESOLVED DUPLICATE of bug 318040

Status

()

Firefox
General
--
minor
RESOLVED DUPLICATE of bug 318040
8 years ago
8 years ago

People

(Reporter: daniel_sowsbery, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3 (.NET CLR 3.5.30729)

When "etc" appears it is corrected to "etc." (i.e. a period is attached), however Firefox does not then recognize "etc." as corrected; it ignores the period.  Therefore whenever "etc" appears it is always marked as incorrectly spelled (whether followed by a period or not) and "etc." always suggested.  The result is a period always being added ("etc.....") if "etc." is selected from the spell-checker's suggestions.

Reproducible: Always

Steps to Reproduce:
1.  Enable spell-checking

2.  Type "etc"

3.  Right/command click the underlined "etc"

4.  Select "etc." from the suggested correct spellings

5.  "etc." is still underlined.  Selecting "etc." again from the spell-checker menu results in "etc.." with the spelling still marked a s incorrect.
Actual Results:  
"etc.." with a period following "etc" for every time the word is corrected.

Expected Results:  
For "etc" to be corrected to "etc.", but then "etc." to be recognised as correct.

Recognise "etc." as a whole word, rather than just looking for "etc" and adding a period.

Comment 1

8 years ago
I tried to reproduce this.  But 3.5.3 (on Vista 64-bit SP2) doesn't mark "etc" or "etc." as misspelled.  Sorry.
(Reporter)

Comment 2

8 years ago
I am using the British English Dictionary (1.19) Add-on.  (Should have mentioned that before, sorry.)

Comment 3

8 years ago
I use the default en-US dictionary.

Comment 4

8 years ago
etc..
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 318040
You need to log in before you can comment on or make changes to this bug.