Mochitests on OSX don't work with --debugger=gdb

RESOLVED FIXED

Status

Testing
Mochitest
RESOLVED FIXED
8 years ago
8 years ago

People

(Reporter: mrbkap, Assigned: mrbkap)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

8 years ago
Created attachment 408614 [details] [diff] [review]
Proposed fix

bug 485531 has come back. It looks like we end up with MOZ_CRASHREPORTER in the environment (probably because we use the same environment to run the ssl tunnel and browser processes). Rather than try to fix this by preventing MOZ_CRASHREPORTER=1 from creeping into the environment (which has been hard thus far), this patch forces the crash reporter to be turned off via MOZ_CRASHREPORTER_DISABLE=1 if we don't want the crash reporter.
Attachment #408614 - Flags: review?(ted.mielczarek)
Possibly a regression from bug 521457.
Attachment #408614 - Flags: review?(ted.mielczarek) → review+
Comment on attachment 408614 [details] [diff] [review]
Proposed fix

This is fine. I wish we could figure out a way to stop breaking this, though.
Assignee: nobody → mrbkap
(Assignee)

Comment 3

8 years ago
http://hg.mozilla.org/mozilla-central/rev/5f884eb3f6b7
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.