jsreftests - js1_5/Regress/regress-344804.js | js1_5/Scope/regress-181834.js FAIL

RESOLVED FIXED in mozilla11

Status

()

Core
JavaScript Engine
RESOLVED FIXED
8 years ago
6 years ago

People

(Reporter: bc, Assigned: RyanVM)

Tracking

Trunk
mozilla11
x86
Windows XP
Points:
---
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

8 years ago
jsreftests - js1_5/Regress/regress-344804.js | js1_5/Scope/regress-181834.js are failing on Windows with Attempt to call default method on object with no default method.
Flags: in-testsuite-
(Reporter)

Comment 1

8 years ago
http://hg.mozilla.org/tracemonkey/rev/930e7e7e9217
mark as failing for windows browser. This is not reproducible in my local vm.
(Reporter)

Comment 2

8 years ago
jorendorff: do you have any idea why this would fail on the unit test machines but not locally?
(Reporter)

Comment 3

8 years ago
Created attachment 417548 [details] [diff] [review]
patch to reenable tests
Comment on attachment 417548 [details] [diff] [review]
patch to reenable tests

ok, let's try it, and we can at least move back to random-if if we've just made it intermittent
Attachment #417548 - Flags: review+
reverted to random-if because of failures reappearing today: http://hg.mozilla.org/mozilla-central/rev/3b4baf256382
In these two tests (and no other tests in jsreftest), we also hit the assertion:

###!!! ASSERTION: Shouldn't ever call this directly!: 'Not Reached', file e:/builds/moz2_slave/mozilla-central-win32-debug/build/dom/plugins/PluginScriptableObjectParent.cpp, line 327

They hit the assertion every time in Windows debug builds, and they also seem to be failing every time.
(Assignee)

Comment 7

6 years ago
They pass locally. Going to push a patch to try to see what happens if I re-enable them for all platforms.

js/src/tests/js1_5/Regress/regress-344804.js
BUGNUMBER: 344804
STATUS: Do not crash iterating over window.Packages
 PASSED! Do not crash iterating over window.Packages

js/src/tests/js1_5/Scope/regress-181834.js
BUGNUMBER: 181834
STATUS: Testing scope
 PASSED! Section 1 of test -
 PASSED! Section 2 of test -
 PASSED! Section 3 of test -
 PASSED! Section 4 of test -
 PASSED! Section 5 of test -
 PASSED! Section 6 of test -
(Assignee)

Comment 8

6 years ago
Created attachment 577177 [details] [diff] [review]
Updated patch

Try likes it too. I had multiple runs triggered and all completed without issue.
https://tbpl.mozilla.org/?tree=Try&rev=bb9dd1ff3610
Attachment #417548 - Attachment is obsolete: true
Attachment #577177 - Flags: review?(bclary)
(Reporter)

Comment 9

6 years ago
Comment on attachment 577177 [details] [diff] [review]
Updated patch

Review of attachment 577177 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks. Can you get one of the JS team to piggy back this patch during a landing?
Attachment #577177 - Flags: review?(bclary) → review+
(Assignee)

Updated

6 years ago
Keywords: checkin-needed

Updated

6 years ago
Assignee: general → ryanvm
Landed:
 https://hg.mozilla.org/integration/mozilla-inbound/rev/8dd8c2258cc2
Keywords: checkin-needed
Target Milestone: --- → mozilla11
Status: NEW → ASSIGNED
https://hg.mozilla.org/mozilla-central/rev/8dd8c2258cc2
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.