Closed Bug 524881 Opened 10 years ago Closed 10 years ago

Beautify nightly.mozilla.org

Categories

(Websites :: other.mozilla.org, defect)

defect
Not set

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: morgamic, Assigned: sgarrity)

References

()

Details

Attachments

(7 files)

Need to add some styles to nightly.mozilla.org so it's more presentable.
No longer depends on: 524879
assigning to jslater to figure out how to proceed.
Assignee: nobody → jslater
Hey David. Over in https://bugzilla.mozilla.org/show_bug.cgi?id=413572 we talked about styling this new nightly page with the mozilla.org theme. Do you have a default page template we could use for this content?

If so, it should be pretty easy to get this beautified, at least on a basic level.
The template Sam put together for planet would probably be the best way to go if you want the mozilla.org branding...
(In reply to comment #3)
> The template Sam put together for planet would probably be the best way to go
> if you want the mozilla.org branding...

Agreed...that would be nice. What's the process for making that happen? I'm not as familiar with the mozilla.org system (I guess this is one of the things we're going to talk about on Thursday).
We want to package things up so the branding can be easily reused in cases like this, but we haven't gotten that far yet.  For now, Sam can probably package up what he did for planet and post it somewhere (or just point to the files in one of the repositories).
I can take this and work up a quick design. Not sure I can own the applying it to the site, but we'll see how far I get.
Assignee: jslater → samuel.sidler
O rly?! We can either modify the generated HTML file to have the same header info as the mozilla.org PHP files or just copy/paste that stuff in.  Let me know if you need help!
Pulling the PHP template files from www.mozilla.org would be ideal -- that will help keep things in sync.  Already I think the footer on www.mozilla.org is different from Planet.
(In reply to comment #8)
> Already I think the footer on www.mozilla.org is different from Planet.

Purposefully different. I don't think all sites should get that huge footer.
That's right -- Planet is a different footer.  I was thinking of mozillians which did borrow the full footer and is now out of sync...
Duplicate of this bug: 535132
Assignee: samuel.sidler → steven
we changed plans. I think we're going for something more spare, like hacks.mozilla.org. up to steven, of course.


lmesa@mozilla.com wrote:
> > First off, who owns this page and who is responsible for updating the
> > files and links?

The page self updates every few hours.

> > Second, I was hoping to use the hacks.mozilla.org design for this
> > page. Is it better to use hacks.m.o versus moz.org design?

hacks.m.o is fine imho. something simple without a lot of navigation to distract from the download links.

blizzard@mozilla.com wrote:
> > I actually would rather see it use somewhat friendlier branding than
> > the hacks stuff - maybe more in tune with what we do with betas?

that's fine too.

- Rob
Can we do a lightweight version of the beta page (http://www.mozilla.com/en-US/firefox/all-beta.html)? The background could be the same light blue, the links could be in the same style as moz.com etc.  No need for buttons or anything fancy, just a little structure and design to make the page a bit more user-friendly.
Any more thoughts on this?
I'll be taking a shot at this, but am not in the office this week. Let me know if it's a high priority issue that should be addressed sooner.
Thanks Steven. Don't worry about working on this until next week. Not the highest priority. 

Have a good New Year!
Hey Steven:

It would be great to have this soon. Anything I can help with?
Poke.  Echoing Laura, would love to see this improved soon.
Steven - webdev can pick this up if you're busy.  Let me know.
The attached file is a locally saved copy of the index.html from nightly.mozilla.org. I just saved it locally and added some (very) basic CSS. It loads a few CSS/image files mozilla.com.

We can probably do better than this with a bit more time - but I get the impression a quick/dirty cleanup might suffice in this case. Let me know if it warrants more effort.

If this works, all that needs to be done is to add the <link> and <style> tags in the <head> and wrap the "There's more stuff..." line in a <p> tag.
Here's a screenshot of what the quick cleanup looks like.
Looks pretty nice.  Only remianing ask is to add the Firefox logo (sans version number) and to make "Nightly Builds" font black. 

Other than that, I think we're ready to go.
(In reply to comment #22)
> Looks pretty nice.  Only remianing ask is to add the Firefox logo (sans version
> number) and to make "Nightly Builds" font black.

I'd actually prefer to keep the headline white, since that's how all the other ones are. I think Laura is reacting to the fact there's no subheadline here, b/c we usually have darker text beneath to balance things out.

Damon, Rsayre...is there anything else we can say here? I don't want to add extraneous text just for the hell of it, but if we could throw in a subhead sentence like "Here's where to get the latest and greatest Firefox builds" (but phrased better) I think it would address what Laura is commenting on.
Would it perhaps be a good idea to add some text to the effect that these aren't stable builds and are only suitable for testing, along with a link to the latest stable release? Just in case anybody stumbles across the page by accident, from Google etc.
(In reply to comment #24)
> Would it perhaps be a good idea to add some text to the effect that these
> aren't stable builds and are only suitable for testing, along with a link to
> the latest stable release? Just in case anybody stumbles across the page by
> accident, from Google etc.
I like that idea...and would welcome any specific thoughts on the exact wording.

Damon, Rsayre?
"Nightlies are automatically built and may be buggy. _Use caution!_  Or _try a release version instead._"

with the first underlined bit linking to http://support.mozilla.com/en-US/kb/Managing+profiles and the second linking to some suitable page?  No need to overthink it.
I don't want to discourage people from downloading the builds with scary text, when they quite likely know exactly what a nightly build is. The subtitle should be "These builds are for testing purposes only.
(In reply to comment #27)
> The subtitle should be "These builds are for testing purposes only."

That sounds good to me. Steven, can you implement using the normal subhead style? 

Also, I agree with Laura's earlier note about adding the Fx logo, too. Thanks!
May I suggest a couple of things?

- how about having nightly.mozilla.org/LOCALECODE/ that would be the same page (without the 64bit build) but with localized builds and potentially translated? We could translate this page as an ongoing goal for 2010 (no deadline, we do it locale by locale when we have time). That would this way also serve the goal of having more community testing on localized builds. I would be interested in working on that in Q2/Q3.

- that's the kind of styling that would have been nice to propose to our community as a way to get involved instead of doing it in-house I think, it would have also promoted this page.
(In reply to comment #29)
> May I suggest a couple of things?

patches welcome
where is the code?
(In reply to comment #31)
> where is the code?

http://hg.mozilla.org/webtools/nightly/
(In reply to comment #28)
> (In reply to comment #27)
> > The subtitle should be "These builds are for testing purposes only."
> 
> That sounds good to me. Steven, can you implement using the normal subhead
> style? 
> 
> Also, I agree with Laura's earlier note about adding the Fx logo, too. Thanks!

OK, once there's a subhead and a logo here, I can get this deployed.
Steven, any word on timing here? I know you still have some other 3.6 projects that take precedence, but let us know.

Thanks-
(In reply to comment #34)
> Steven, any word on timing here? I know you still have some other 3.6 projects
> that take precedence, but let us know.

This shouldn't take much more time - if I can't get it done over the weekend, I'll get it done on Monday.
Blocks: 540022
Sorry if this is off-topic for a theme update, but the people who made this page happen are here so I'm gonna give it a shot :-)

Can we get Fennec nightly builds linked here as well? Typing on a mobile browser is hard and it'd be nice to have one location with a reasonably short URL where we could point people to for downloading the latest Fennec nightlies. This page fits that description pretty well.
(In reply to comment #36)
> Can we get Fennec nightly builds linked here as well?

... or even Thunderbird, Camino, or SeaMonkey. This is nightly._mozilla.org_, after all, and not nightly.firefox.com or nightly.mozilla.com.
Comments #36 and 37 make sense to me. But...

...we shouldn't wait on those to get the other changes implemented. I say we get the page cleaned up for Firefox like we've been discussing and then work on adding the other ones.
(In reply to comment #37)
> (In reply to comment #36)
> > Can we get Fennec nightly builds linked here as well?
> 
> ... or even Thunderbird, Camino, or SeaMonkey. This is nightly._mozilla.org_,
> after all, and not nightly.firefox.com or nightly.mozilla.com.

Right, I would really prefer to have this as an access point to all _mozilla.org_ nightly builds, not just one "random" product's (even if desktop Firefox is by far the most-used product).
We do have localized nightlies, and we do want international coverage of our code, so I'd like to echo what Pascal said, we should take a stab on getting localized builds exposed.

Caveat, the list of locales that we have on central is subject to change, I'm still on the hook to slim it down a bit.
(In reply to comment #39)
> Right, I would really prefer to have this as an access point to all
> _mozilla.org_ nightly builds, not just one "random" product's (even if desktop
> Firefox is by far the most-used product).

http://hg.mozilla.org/webtools/nightly/
This patch adds the necessary CSS hooks and slight HTML changes needed for the basic styling of this page. Image and CSS file to come.
This PNG is assumed to be in the output dir.
This CSS file is assumed to be in the output dir.

The patch, PNG, and CSS file I've attached here really just add basic styling to the nightly page. Adding additional products/projects and/or locales should probably be another bug. If someone wants to file that and give me some specs (what projects will be included, what platforms they build for), I'd be glad to work on it.
Attachment #422102 - Flags: review?(morgamic)
Comment on attachment 422102 [details] [diff] [review]
thunderbird+seamonkey

this is not the right bug for this patch, but also:

https://bugzilla.mozilla.org/show_bug.cgi?id=413572#c6

build out the "more stuff" page instead of adding to the front page. The whole point of the nightly site is not to list everything, like the ftp site does.
Attachment #422102 - Flags: review?(morgamic) → review-
sayrer, if the page is not supposed to list other mozilla.org products, then place it at getfirefox.xom, and not a .mozilla.org site, please.

I'm happy timeless came up with the patch, but I'm not sure this site is even headed the right way, as Firefox-only design as well as the branded Firefox logo are the right way to go here, esp. as the builds downloaded from it are unbranded by themselves.
(In reply to comment #47)
> sayrer, if the page is not supposed to list other mozilla.org products, then
> place it at getfirefox.xom, and not a .mozilla.org site, please.

I don't think that's a requirement at all. Not every page at www.mozilla.org must give equal billing to all Mozilla projects.
(In reply to comment #47)
> sayrer, if the page is not supposed to list other mozilla.org products, then
> place it at getfirefox.xom, and not a .mozilla.org site, please.

Settle down, the namespace is not crowded. More users on Firefox nightlies helps every Gecko project, so maybe you should reconsider all this bikeshedding. 

Anyway, I fixed the way-old obvious bug to make this site, so I own it. My policy is this: if you don't like something, find me and others on irc and have a civil discussion. Bickering via self-righteous bug comments won't work.
(In reply to comment #49)
> (In reply to comment #47)
> > sayrer, if the page is not supposed to list other mozilla.org products, then
> > place it at getfirefox.xom, and not a .mozilla.org site, please.
> 
> Settle down, the namespace is not crowded. More users on Firefox nightlies
> helps every Gecko project, so maybe you should reconsider all this
> bikeshedding. 

Not any bit more than more SeaMonkey, Thunderbird or whatever other Gecko application nightly users, so that's a simple non-argument.

> Anyway, I fixed the way-old obvious bug to make this site, so I own it.

That is supposed to be a "civil" argument? Actually, that's the attitude that brings more and more developers away from the Mozilla project and over to alternatives that are more appreciative of having more than one product using their code - it looks like some Firefox people seem to be mistaking "one Mozilla" for "Firefox is trampling on everyone else". And the beast shall come forth sourrounded by a roiling cloud of vengance and stomp on any of its children before eating them?
(In reply to comment #50)
> (In reply to comment #49)
> > (In reply to comment #47)
> > > sayrer, if the page is not supposed to list other mozilla.org products, then
> > > place it at getfirefox.xom, and not a .mozilla.org site, please.
> > 
> > Settle down, the namespace is not crowded. More users on Firefox nightlies
> > helps every Gecko project, so maybe you should reconsider all this
> > bikeshedding. 
> 
> Not any bit more than more SeaMonkey, Thunderbird or whatever other Gecko
> application nightly users, so that's a simple non-argument.

"Not any bit more" in reply to "More users on Firefox nightlies helps every Gecko project" is false, because Firefox has two or three orders of magnitude more users, so it test-covers more of Gecko loading web content than other apps.

There are use-cases in XUL and app-specific embeddings that won't be covered but they are the minority.

Anyway, see Asa's comment 48.

/be
Steven: i'd like to underscore a point raised by Robert. The builds you're advertising do *not* have Official branding. Does this site actually have a mission statement?
(In reply to comment #51)
> "Not any bit more" in reply to "More users on Firefox nightlies helps every
> Gecko project" is false, because Firefox has two or three orders of magnitude
> more users, so it test-covers more of Gecko loading web content than other
> apps.

What I meant is an additional Firefox nightly tester is not more helpful for Gecko testing than an additional SeaMonkey tester, for example.

> Anyway, see Asa's comment 48.

And I even think that one is BS, as the current strategy is "one Mozilla", not "one Firefox disguised as Mozilla".
Brendan: coverage is a funny thing. There's a bug I just patched today which was reported actively by Thunderbird users but which once fixed helps Firefox users who were not actively reporting it.

(Date parsing on OS X, fun.)

At what point will you subscribe to a law of diminishing returns?
Regardless of the heavy-handed reaction to even the mere proposal of including other projects, this bug is about styling the site, not about a content discussion.

This seems like a newsgroup discussion type of situation.
(In reply to comment #55)
> Regardless of the heavy-handed reaction to even the mere proposal of including
> other projects, this bug is about styling the site, not about a content
> discussion.
> 
> This seems like a newsgroup discussion type of situation.

+1 for that. It's worth remembering that this bug is simply about adding a nicer theme to the existing site, which only includes Firefox links at the moment. 

The other stuff seems like a very worthy and important topic for discussion, and we should certainly figure it out, but it's out of scope for 524881.
I filed bug 540311 to deal with adding other products/projects to nightly.mozilla.org. Let's leave this bug to "beautifying" the current page somehow and move any other discussion to other bugs.
Status: NEW → ASSIGNED
(In reply to comment #54)
> Brendan: coverage is a funny thing. There's a bug I just patched today which
> was reported actively by Thunderbird users but which once fixed helps Firefox
> users who were not actively reporting it.
> 
> (Date parsing on OS X, fun.)

Tell me something I don't know. This doesn't alter the coverage benefits of Firefox vs. other apps, _in toto_.

> At what point will you subscribe to a law of diminishing returns?

We have nowhere near total web compat test coverage. I explicitly adverted to code covered by other apps that Firefox doesn't. But that still doesn't affect the magnitudes of users or web content pumped through Gecko in Firefox vs. other apps.

Newsgroup time.

/be
Sorry for helping push this bug off course. I should have filed a new one asking for Mobile Firefox to be added to this page. I'll follow-up elsewhere (maybe bug 540311, if at all). 

This bug was about styling up the page and I don't want to derail that activity. Please return to your previous work and ignore my comments here. Thanks.
I don't have commit access to the hg repo, but the last three files I attached should be ready to go for this now. Robert?
yeah, I'm the bottleneck here, sorry. I'll get it patched (I have to break up the file into a few template pieces).
Hey Rob--how's this coming?
We need this now, please.
yes boss
Attachment #423866 - Flags: review?(morgamic)
Comment on attachment 423866 [details] [diff] [review]
beautification patch

Yes please! Looks good.
Attachment #423866 - Flags: review?(morgamic) → review+
http://hg.mozilla.org/webtools/nightly/rev/cd1d8c180086
Status: ASSIGNED → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
So what happens now? Steven?
I filed a bug to get it pushed.  It will take care of it.
Verified FIXED on http://nightly.mozilla.org/.
Status: RESOLVED → VERIFIED
OS: Linux → All
Hardware: x86 → All
Is there another bug to fix the static build on may 19th under every link?  

I would say this needs to go as it doesn't serve a purpose if its not going to be dynamically updating the date of the most recent build.
(In reply to comment #70)
> Is there another bug to fix the static build on may 19th under every link?  
> 

yes, we just fixed bug 567385
You need to log in before you can comment on or make changes to this bug.