[mozmill] Private Browsing tests failing on 1.9.1 and 1.9.2

RESOLVED FIXED

Status

Mozilla QA
Mozmill Tests
RESOLVED FIXED
9 years ago
8 years ago

People

(Reporter: aaronmt, Assigned: whimboo)

Tracking

({regression})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [MozMill1.3Testday][mozmill-test-failure])

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
The following tests ran on 1.9.1.4 are failing

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.1.4) Gecko/20091016 Firefox/3.5.4

Controller.assertProperty() failed

function () { pb.enabled = false; pb.showPrompt = false; UtilsAPI.closeAllTabs(controller); pb.start(); controller.open(websites[0]); controller.waitForPageLoad(); var property = mozmill.isWindows ? "popupWarningButton.accesskey" : "popupWarningButtonUnix.accesskey"; var accessKey = UtilsAPI.getProperty("chrome://browser/locale/browser.properties", property); controller.keypress(null, accessKey, {ctrlKey: mozmill.isMac, altKey: !mozmill.isMac}); var allow = new (elementslib.XPath)(controller.window.document, "/*[name()='window']/*[name()='popupset'][1]/*[name()='popup'][2]/*[name()='menuitem'][1]"); controller.waitForElement(allow); controller.assertProperty(allow, "disabled", true); controller.keypress(null, "VK_ESCAPE", {}); controller.open(websites[1]); controller.waitForPageLoad(); var image = new (elementslib.XPath)(controller.tabs.activeTab, "/html/body[@id='cnnMainPage']/div[@id='cnnHeader']/div/div/a/img"); var blockImages = new (elementslib.ID)(controller.window.document, "context-blockimage"); controller.rightClick(image); controller.assertProperty(blockImages, "hidden", true); PrefsAPI.preferencesDialog.open(prefCookieHandler); var md = new (ModalDialogAPI.modalDialog)(cookieHandler); md.start(); controller.open(websites[2]); controller.waitForPageLoad(); pb.stop(); }

and test

timeout exceeded for waitForEval('subject.getMostRecentWindow('').document.documentElement.id == 'unknownContentType'')

function () { PrefsAPI.preferencesDialog.open(handlePrefDialog); for (var ii = 0; ii < downloads.length; ii++) { DownloadsAPI.downloadFileOfUnknownType(controller, downloads[ii]); } controller.sleep(100); controller.waitForEval("subject.activeDownloadCount == 0", 30000, 100, dm); curDownloads = dm.getAllDownloads(); pb.start(); dm.open(controller); var downloadView = new (elementslib.ID)(dm.controller.window.document, "downloadView"); dm.controller.waitForElement(downloadView, gTimeout); dm.controller.waitForEval("subject.itemCount == 0", gTimeout, 100, downloadView.getNode()); dm.close(); DownloadsAPI.downloadFileOfUnknownType(controller, downloadsPB[0]); controller.sleep(100); controller.waitForEval("subject.activeDownloadCount == 0", 30000, 100, dm); curDownloads = curDownloads.concat(dm.getAllDownloads()); pb.stop(); dm.open(controller); downloadView = new (elementslib.ID)(dm.controller.window.document, "downloadView"); dm.controller.waitForElement(downloadView, gTimeout); dm.controller.waitForEval("subject.itemCount == " + downloads.length, gTimeout, 100, downloadView.getNode()); for (var ii = 0; ii < downloads.length; ii++) { var item = new (elementslib.ID)(dm.controller.window.document, "dl" + (ii + 1)); dm.controller.assertJS(item.getNode().getAttribute("uri") == downloads[ii]); } dm.close(); }
(Reporter)

Updated

9 years ago
Whiteboard: [MozMill1.3Testday]
(Reporter)

Comment 1

9 years ago
These are part of 

A) testDownloadManagerClosed.js
B) testDisabledPermissions.js

Comment 2

9 years ago
I know near to nothing about MozMill, but is there anything I can help with here?
(Assignee)

Comment 3

9 years ago
I tried to reach you via IRC yesterday but was not lucky. So lets explain it here...

Lately I have seen that when switching out of PB mode we close the window and open a new one again. It only happens sometimes and not everytime. I haven't had a change to check those broken tests yet, because I had to do a complete reinstall of my system today. I'll hopefully come to it within the next days and give more detailed information if necessary.

Comment 4

9 years ago
(In reply to comment #3)
> Lately I have seen that when switching out of PB mode we close the window and
> open a new one again. It only happens sometimes and not everytime. I haven't
> had a change to check those broken tests yet, because I had to do a complete
> reinstall of my system today. I'll hopefully come to it within the next days
> and give more detailed information if necessary.

Does it happen in case more than one window is open?
(Assignee)

Comment 5

9 years ago
I hope to have a fix for the 5 broken tests by tomorrow.
Assignee: nobody → hskupin
Status: NEW → ASSIGNED
(Assignee)

Comment 6

9 years ago
Created attachment 416240 [details] [diff] [review]
Patch v1

This patch will fix four broken tests. Mostly we failed while waiting for elements on Bugzilla since the upgrade happened. Further the failure descriptions are more descriptive now.
Attachment #416240 - Flags: review?(adesai)
Attachment #416240 - Flags: review?(adesai) → review+
(Assignee)

Comment 7

9 years ago
Landed as:
http://hg.mozilla.org/qa/mozmill-tests/rev/99646610275c
http://hg.mozilla.org/qa/mozmill-tests/rev/4f1068047c56
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Summary: [mozmill] Private Browsing tests failing on 1.9.1.4 → [mozmill] Private Browsing tests failing on 1.9.1 and 1.9.2
(Assignee)

Updated

9 years ago
Blocks: 527983
(Assignee)

Updated

8 years ago
Keywords: regression
(Assignee)

Updated

8 years ago
Whiteboard: [MozMill1.3Testday] → [MozMill1.3Testday][mozmill-test-failure]
(Assignee)

Comment 8

8 years ago
Mass move of Mozmill Test related project bugs to newly created components. You can filter out those emails by using "Mozmill-Tests-to-MozillaQA" as criteria.
Component: Private Browsing → Mozmill Tests
Product: Firefox → Mozilla QA
QA Contact: private.browsing → mozmill-tests
Version: 3.5 Branch → unspecified
You need to log in before you can comment on or make changes to this bug.