Last Comment Bug 525300 - Make it simpler to test modal dialogs (e.g. alert/confirm/prompt).
: Make it simpler to test modal dialogs (e.g. alert/confirm/prompt).
Status: RESOLVED FIXED
:
Product: Toolkit
Classification: Components
Component: XUL Widgets (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla1.9.3a1
Assigned To: Nochum Sossonko [:Natch]
:
: Neil Deakin
Mentors:
Depends on:
Blocks: 498648 543071
  Show dependency treegraph
 
Reported: 2009-10-29 13:13 PDT by Nochum Sossonko [:Natch]
Modified: 2010-01-30 14:07 PST (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
beta2-fixed
.8-fixed


Attachments
patch (727 bytes, patch)
2009-10-29 13:13 PDT, Nochum Sossonko [:Natch]
no flags Details | Diff | Splinter Review
"common-dialog-loaded" (726 bytes, patch)
2009-10-29 13:23 PDT, Nochum Sossonko [:Natch]
enndeakin: review+
mbeltzner: approval1.9.2+
Details | Diff | Splinter Review

Description Nochum Sossonko [:Natch] 2009-10-29 13:13:18 PDT
Created attachment 409160 [details] [diff] [review]
patch

This would be nice instead of hacking around with nsIComponentReistrar.
Comment 1 Neil Deakin 2009-10-29 13:16:36 PDT
The topic name would be better described as 'common-dialog-loaded'
Comment 2 Nochum Sossonko [:Natch] 2009-10-29 13:23:00 PDT
Created attachment 409163 [details] [diff] [review]
"common-dialog-loaded"

Done.
Comment 3 Nochum Sossonko [:Natch] 2009-10-29 13:59:31 PDT
This is needed for the test in bug 498648.
Comment 5 Mike Beltzner [:beltzner, not reading bugmail] 2009-10-30 10:20:14 PDT
Comment on attachment 409163 [details] [diff] [review]
"common-dialog-loaded"

a192=beltzner
Comment 7 :Ehsan Akhgari 2010-01-30 14:04:28 PST
The patch for this bug has landed on 1.9.1 as part of bug 498648, but that patch did not work because the observerService variable was undeclared in 1.9.1.  This patch fixes the issue:

http://hg.mozilla.org/releases/mozilla-1.9.1/rev/6f4f1c26308a

This patch also fixes the perma-orange in bug 543071.

Note You need to log in before you can comment on or make changes to this bug.